Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

"installed libcurl version doesn't support this curl" problem

"installed libcurl version doesn't support this curl" problem

Rising Star

The spark livy alert always reports an alert : Connection failed on host ***:8999

In detail, it prints ExecutionFailed: Execution of 'curl -s o /dev/null -w'%{http_code} --negotiate -u: -k http://host:8999/session | grep 200' return 1, curl: option --negotiate: the installed liburl version doesn't support this curl: try curl --help...

I have 3 host in this cluster, but only one host report this alert. I have checked the curl version and libcurl on hosts respectively, and they are all same. It may caused by installing anaconda and python version changing, but I am not sure as default python version is 2.6.

How to fix it? Thanks!

3 REPLIES 3

Re: "installed libcurl version doesn't support this curl" problem

Super Mentor

@Junfeng Chen

Error indicates that the "libcurl" version which you are uisng in your Anaconda is too old and does not support "--negotiate" flag with curl command.

So can you please let us know how you checked the "libcurl" and Curl version on your hosts? What version of "libcurl" do you see when you run the following command. By any chance do you have multiple Curl versions installed on the host?

Example:

# curl -V

curl 7.29.0 (x86_64-redhat-linux-gnu) libcurl/7.29.0 NSS/3.34 zlib/1.2.7 libidn/1.28 libssh2/1.4.3
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp scp sftp smtp smtps telnet tftp 
Features: AsynchDNS GSS-Negotiate IDN IPv6 Largefile NTLM NTLM_WB SSL libz unix-sockets 

.

Can you try upgrading Curl / libcurl on your host?

Similar thread: https://community.hortonworks.com/questions/70994/hiveserver2-failing-with-tmptmp23xnha-2tmptmpyf2fo...

Re: "installed libcurl version doesn't support this curl" problem

Rising Star

Thanks Jay.

I checked curl and libcurl version by running "yum list | grep curl", their version is .

curl.x86_64 7.19.7-46.el6

libcurl.x86_64 7.19.7-46.el6

python-pycurl.x86_64 7.19.0-8.el6

libcurl.i686 7.19.7-46.el6

libcurl-devel.i686 7.19.7-46.el6

libcurl-devel.x86_64 7.19.7-46.el6

curl -V prints the following info:

curl 7.19.7(x86-64-redhat-linux-gnu) libcurl/7.19.7...

Protocals:...

Features: GSS-Negotiate ...

If I run the alert_spark2_livy_port.py script independently, it runs well

What confuse me is, all my three hosts have the complete same version of curl, but only one have the above problem.

Highlighted

Re: "installed libcurl version doesn't support this curl" problem

New Contributor
@Junfeng Chen

I am facing a similar problem , can you please share the steps you performed to resolve it.