Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

"jdbc:postgresql://%HOSTGROUP::prodnode1%:5432/hive" Can't mapping to host.

"jdbc:postgresql://%HOSTGROUP::prodnode1%:5432/hive" Can't mapping to host.

New Contributor

I custom the blueprint install hive service and use the external postgresql database, but the %HOSTGROUP::prodnode1% can't reslove the host name, 

my code:

 

{
      "hive-site":{
        "properties":{
          "javax.jdo.option.ConnectionDriverName":"org.postgresql.Driver",
          "javax.jdo.option.ConnectionURL":"jdbc:postgresql://%HOSTGROUP::prodnode1%:5432/hive",
          "javax.jdo.option.ConnectionUserName":"hive",
          "javax.jdo.option.ConnectionPassword":"hive",
          "hive.security.authorization.enabled":"true",
          "hive.server2.logging.operation.log.location":"/tmp/hive/operation_logs"
        }
      }
    },

 

 

And export the blueprint from an exists cluster , In the blueprint , It's same as my code 

 

...
          "hive.server2.tez.default.queues" : "default",
          "hive.server2.tez.sessions.per.default.queue" : "1",
          "hive.server2.thrift.http.port" : "10001",
          "hive.server2.logging.operation.log.location" : "/tmp/hive/operation_logs",
          "javax.jdo.option.ConnectionURL" : "jdbc:postgresql://%HOSTGROUP::host_group_1%:5432/hive",
...

 

 

I search the issue here, like this https://community.cloudera.com/t5/Support-Questions/Ambari-HA-Blueprint-HOSTGROUP-syntax-not-getting... 

 

"I don't have Oozie HA and I've got the problem also. All hostgroups are failing to be substituted. I'm using an external Postgresql 9.2 database, are their known issues with this?"

 

please help me , i have two question:

- the external database in blueprint , can't reslove %HOSTGROUP::prodnode1% ? why ? 

- I want to know the blueprint syntax with "%HOSTGROUP::prodnode1%" or other syntaxn ?  I don't find any relation artile . 

 

thank you very much . 

1 REPLY 1
Highlighted

Re: "jdbc:postgresql://%HOSTGROUP::prodnode1%:5432/hive" Can't mapping to host.

New Contributor

When install the cluster with blueprint , the "Database URL" is Wrong.

 

cockdad_0-1586158119619.png

 

 

Don't have an account?
Coming from Hortonworks? Activate your account here