Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

ranger kms health is unhealthy and failing pyspark job write to lake

avatar
Frequent Visitor

production pyspark jobs failure, on prem cloudera version 7.1.8 not supported at present. 

ranger kms health is unhealthy and failing pyspark job write to lake

 

any suggestion to resolve ranger kms server issues. 

1 ACCEPTED SOLUTION

avatar
Frequent Visitor

certificate used in ranger KMS expired which caused the pyspark job to fail. we renewed the certificate and update KMS configuration. now jobs are running fine. 

View solution in original post

3 REPLIES 3

avatar
Community Manager

@s-raju Welcome to the Cloudera Community!

To help you get the best possible solution, I have tagged our Ranger experts @vamsi_redd @Puni  who may be able to assist you further.

Please keep us updated on your post, and we hope you find a satisfactory solution to your query.


Regards,

Diana Torres,
Senior Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

avatar
Master Collaborator

Hello @s-raju 

Thank you for reaching out to Cloudera community

Can you please share the exact error with Ranger KMS? Did you tried restarting Ranger KMS? Are there any errors in Ranger KMS logs? 

What error are we facing job ?

Thank you

Kshitij Upadhyay

avatar
Frequent Visitor

certificate used in ranger KMS expired which caused the pyspark job to fail. we renewed the certificate and update KMS configuration. now jobs are running fine.