Support Questions

Find answers, ask questions, and share your expertise

ranger permissions issue with user account


ranger.pngranger1.pnghi i have configured ranger on my ambari machine( and i created linux user account on same machine and tring to put the data in HDFS from this created account. it was throwing an error as below.

[venky@ham ~]$ hdfs dfs -put /home/venky/sam3.txt /apps put: Permission denied: user=venky, access=WRITE,


[venky@ham ~]$

i followed as below screen shots to enable the access for venky user account on HDFS in ranger.

clicked on test connection and passed successfully.

Now service has created under HDFS with the policy name, clicked on the edit from the action then mentioned the resource path and then from user and group permissions selected the user name as (venky) and permissions has given RWX then saved. but no luck. can anyone help me



@Balaji Vemula

I see that the file permisions are hdfs:hdfs whereas you want the user venky to be able to read,write and execute NOT so ?

Please adjust the file permissions for the local and hdfs accordingly and it will work


Geoffrey, thank you for your response, capture.pngnow the file permissions are with same user venky at OS level and still getting the same error as screen shot below. if you can help in this like how to set the appropriate permissions in HDFS.


i tried using acls on hdfs as below command , its working fine

#hdfs dfs -setfacl -m user:venky:rwx /apps

now venky able to write the files to HDFS.

but when i giving the same dir access to users from ranger its not working. can you help me


@@Balaji Vemula

Are you trying to put in hdfs or local filesystem?

# su - hdfs

Then create a directory

$ hdfs dfs -mkdir  /user/venky
$ hdfs dfs -chown venky:hadoop /user/venky

Then try your put command ,