Support Questions

Find answers, ask questions, and share your expertise

[root@server lib]# ambari-agent start bash: /var/lib/ambari-agent/bin/ambari-agent: Permission denied


Hello Community


I am trying to start the ambari agent with root account but I got permission denied

any idea please? 😞


[root@luapp699 lib]# ambari-agent start
bash: /var/lib/ambari-agent/bin/ambari-agent: Permission denied


Thanks and regards




What OS are you running ? Have you checked the permissions on that file?


#  chmod u+x /var/lib/ambari-agent/bin/ambari-agent

Then try starting else use the sudo option

# sudo ambari-agent start



No vain ;(


It is centos 7


-rwxr-xr-x. 1 root root 10751 Aug 22 02:11 ambari-agent
[root@luapp699 bin]# sudo ambari-agent start
bash: /var/lib/ambari-agent/bin/ambari-agent: Permission denied


Actually, I have installed all nodes and I could connect to nodes from master via SSH

But When I tried to validated hots i hot  failed with this error :

Error while bootstrapping:
/usr/bin/env: ambari-python-wrap: No such file or directory

 I could not find ambari-agent in slaves node so i tried to install manually agent machines, shall I do this? 

and when i tried to start an agent i got permission denied

Should I do this? i'm in real mess ..




Super Mentor


Try reinstalling Ambari Agent Binaries once.


Ideally there should be a Symlink created as following when you successfully install Ambari Agent Binary to a host. The symlink points to a Python binary installed on that host.





#  ls -lart /usr/bin/ambari-python-wrap
lrwxrwxrwx. 1 root root 15 Feb 15  2019 /usr/bin/ambari-python-wrap -> /usr/bin/python





Try reinstalling ambari agent.




# which python
# ls -l /usr/bin/python
# /usr/bin/python -V

# yum reinstall ambari-agent
# ls -lart /usr/bin/ambari-python-wrap