Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

schema registry ui not accesible

schema registry ui not accesible

I have co hosted both HDP and HDF using the same ambari. the cluster is kerberised too. After installing schema registry of HDF, i am not able to access the UI. I am prompted for a user name/password. I tried some kerberos principals and passwords, but none of them worked. i do see an error like this. IS there a way to avoid this or even skip kerberos for the registry UI.

Ambari used is 2.5.2

HDf - 3.0


Problem accessing /. Reason:

    GSSException: Defective token detected (Mechanism level: GSSHeader did not find the right tag)

Re: schema registry ui not accesible

Super Mentor


After setting the Kerberos , Have you also enabled SPNEGO? If yes then please check if on your Browser (like FireFox) you have set the below properties as well?

network.auth.use-sspi false 


As mentioned in the following link:


Re: schema registry ui not accesible

@Jay SenSharma, i didnt enable spnego for any of the services. other service ui's i am able to access without any issues. Is there a way to disable spnego for registry alone, i couldn't find that option in ambari


Same question here!On a kerberos ena ...

Same question here!

On a kerberos enabled cluster, where we do not (yet) want to have (all) UIs properly (SPNEGO) kerberized, I did not find a (documented) way to get the Schema Registry working without authentication.


However i found a work around (hack), to use the registry w//out security, by adding a line


directly in following file (version used in HDF-3.2.0), before Line 101:


Plz note: I'ld prefer to get rid of that hack

but I could not find any proper Doc in the HWX HDF Docs.

The most detailed Registry Doc I found (that does not directly relate to the respective Ambari registry configs):

Don't have an account?
Coming from Hortonworks? Activate your account here