Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.




When I am executing the below query it is failing. When I execute the same query in other environments (cluster) it is displaying the results. I have checked the table description using "describe extended table" this is also same in other environments also.

Help me on this

hive> SELECT * FROM udasv_XXX.udas_dtv_XXXX_XXX limit 10;
FAILED: RuntimeException org.apache.hadoop.hive.ql.metadata.HiveException: Failed with exception Property serialization.lib cannot be nulljava.lang.IllegalStateException: Property serialization.lib cannot be null
        at org.apache.hadoop.hive.ql.plan.PartitionDesc.getDeserializerClassName(
        at org.apache.hadoop.hive.ql.exec.FetchOperator.needConversion(
        at org.apache.hadoop.hive.ql.exec.FetchOperator.setupOutputObjectInspector(
        at org.apache.hadoop.hive.ql.exec.FetchOperator.initialize(


Rising Star

@shyam gurram

Can you check the SerdeInfo for the partitions under this table udasv_XXX.udas_dtv_XXXX_XXX using below command:

desc formatted udasv_XXX.udas_dtv_XXXX_XXX partition (name=value);

It looks like serde lib is missing from some partitions. Can you compare it with partitions in another environment where it worked fine.


Thank for your reply,

I figure it out. There is a partition issue. I have dropped and add the partition, now it is working fine. Thanks for the help.

Rising Star
@shyam gurram

Great, that it worked !

This issue was only for 1 or few partitions, that's the reason limit 10 worked.

Can you please accept and upvote the answer.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.