Support Questions

Find answers, ask questions, and share your expertise

solr security file not located where it searches in zookeeper

New Contributor

Hello guys,

I set up a HDP guarded by kerberos.

Everything seems to be OK except for Atlas which keeps down and cannot be started.

When I tried to start Atlas I find error log pointed to solr.

In the log of Solr I found things like below:

Caused by: org.apache.zookeeper.KeeperException$AuthFailedException: KeeperErrorCode = AuthFailed for /security.json
	at org.apache.zookeeper.KeeperException.create(KeeperException.java:126)
	at org.apache.zookeeper.KeeperException.create(KeeperException.java:54)
	at org.apache.zookeeper.ZooKeeper.exists(ZooKeeper.java:1105)
	at org.apache.solr.common.cloud.SolrZkClient.lambda$exists$3(SolrZkClient.java:316)
	at org.apache.solr.common.cloud.ZkCmdExecutor.retryOperation(ZkCmdExecutor.java:60)
	at org.apache.solr.common.cloud.SolrZkClient.exists(SolrZkClient.java:316)
	at org.apache.solr.common.cloud.ZkStateReader.getSecurityProps(ZkStateReader.java:1008)
	... 42 more

Then I go to zookeeper and find the security.json file located in /infra-solr/security.com

Thus I think this could be the reason of failure.

Does anyone have idea about change the location where solr tried to look for security.json?

Thank you!

2 REPLIES 2

Contributor

security.json is avialble under /infra-solr znode.

you can login to zkcli and verify the same.

# /usr/hdp/current/zookeeper-client/bin/zkCli.sh
[zk: localhost:2181(CONNECTED) 0] ls /
[registry, cluster, controller, brokers, zookeeper, infra-solr, admin, isr_change_notification, hiveserver2, controller_epoch, druid, rmstore, ambari-metrics-cluster, consumers, config]
[zk: localhost:2181(CONNECTED) 1] ls /infra-solr
[configs, overseer, aliases.json, live_nodes, collections, overseer_elect, security.json, clusterstate.json, clusterprops.json]

you can also verify it through Solr web UI.

88480-securityjasonscreen-shot.png

New Contributor

Thank you for your answer. I restart the solr and the configuration file appears. I think it may be caused by a mis-configuration days before I get the cluster.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.