Support Questions
Find answers, ask questions, and share your expertise

to add services in hdp-2.5. ambari-2.4.0.1

Solved Go to solution
Highlighted

Re: to add services in hdp-2.5. ambari-2.4.0.1

New Contributor
,

@Paul McQuesten Based on the error msg below, I think that I have the solution to your problem.

"Uncaught TypeError: Cannot read property 'repository_versions' of undefinedapp.js:53802"

1) Go to Manage Ambari

2) Under Clusters, click Versions

3) Looking at the version that you are trying to deploy, see if how many are listed as Current: X/Y

4) If X is less than Y, then it appears as though you have an issue on one (or more) of your hosts.

5) Place affected hosts in maintenance mode (Ambari --> Hosts --> Click on affected host name --> Host Actions)

6) Reinstall Failed Components (Ambari --> Hosts --> Select affected hosts --> Actions --> Selected Hosts)

This might take some time to complete.

7) Turn off maintenance mode

8) Check the Manage Ambari Versions page to see if they have all been resolved.

-------------

Additionally, you might want to check for issues on each server using hdp-select status. These might represent install issues that you have to clean up. I took care of that ahead of time so I am not sure if the wizard will resolve it.

For more info: hdp-select --help

------------

After that the wizard worked fine for me

Highlighted

Re: to add services in hdp-2.5. ambari-2.4.0.1

Super Collaborator

+1 - @Misti Mordoch - This seems to have fixed the problem for someone else I was talking to. You can also check for out of sync hosts with the Rest API: http://:8080/api/v1/clusters//stack_versions/1>:8080/api/v1/clusters/<CLUSTER_NAME>/stack_versions/1 -u <USERNAME> and then Check for       "OUT_OF_SYNC" : [ ] to make sure there are no hosts list as out of sync. Reinstall services for out of sync hosts or remove the hosts and re-add will probably fix it.

Highlighted

Re: to add services in hdp-2.5. ambari-2.4.0.1

New Contributor

I encounter exact the same js error and in step 3, my cluster shows Current: 14/16.

However, there is no error on hosts under Ambari--> Hosts(All hosts are marked with green tick)

Cloud you give more information on how to find our the failed components?

====> Update 1:

I think the reason my cluster shows Current: 14/16 may be that I also install Solr(2 nodes) via Ambari

http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.5.0/bk_solr-search-installation/content/ch_hdp-s...

the [Current Version:] section of the 2 Solr nodes (e.g. Hosts--->solr01.company.com) are empty.

====> Update 2:

Based on the thoughts in Update 1, I delete the installed Solr service, then the error disappears. Now the "Add Service" function works well. But it seems that I need to find another way to deploy Solr(a standalone Solr cluster or install Solr via Ambari after all the other services are installed.)

Re: to add services in hdp-2.5. ambari-2.4.0.1

Still having this problem....

Installed from scratch a third time same exact issue. Did minimal installs before and full on install this time.... same issue

9034-ambari-error.png

Can you tell me what component the repository version is looking at?

Highlighted

Re: to add services in hdp-2.5. ambari-2.4.0.1

New Contributor

9057-ambari-versions.png

Where it says Current: 6/6, it was 5/6 when I noticed my issue. It was not a particular component that was the issue for me. But there was a hiccup during the original install.

Highlighted

Re: to add services in hdp-2.5. ambari-2.4.0.1

New Contributor

Hi,

We had this issue working with MySQL as Ambari's backend database.

What helped us solve this issue was updating a table called "cluster_version", it seemed that from some reason Ambari didn't update the "state" field of this table on cluster initial installation.

We found it by running over Amvari's web javascript code, located the REST API call for stack version, then finally finding the table name in the java code.

This is the update clause we used:

UPDATE ambari.cluster_version SET state = 'CURRENT';

Hope it helps.

View solution in original post

Highlighted

Re: to add services in hdp-2.5. ambari-2.4.0.1

New Contributor

This solved my issue. In my case, the ambari database is a postgresql Database.