Support Questions
Find answers, ask questions, and share your expertise

unable to install nifi with java 11

Solved Go to solution

unable to install nifi with java 11

New Contributor

Hello,

I'm trying to install NIFI 1.7.1 on windows having java 11.0.1 installation. But everytime I launch the run-nifi.bat file, It immediately stops and I have this in my log file :

2018-10-18 18:50:54,616 INFO [main] o.a.n.b.NotificationServiceManager Successfully loaded the following 0 services: []
2018-10-18 18:50:54,626 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_STARTED
2018-10-18 18:50:54,626 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_STOPPED
2018-10-18 18:50:54,626 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_DIED
2018-10-18 18:50:54,654 INFO [main] org.apache.nifi.bootstrap.Command Starting Apache NiFi...
2018-10-18 18:50:54,654 INFO [main] org.apache.nifi.bootstrap.Command Working Directory: E:\NIFI\nifi-1.7.1
2018-10-18 18:50:54,657 INFO [main] org.apache.nifi.bootstrap.Command Command: C:\Program Files\Java\jdk-11.0.1\bin\java.exe -classpath E:\NIFI\nifi-1.7.1\.\conf;E:\NIFI\nifi-1.7.1\.\lib\javax.servlet-api-3.1.0.jar;E:\NIFI\nifi-1.7.1\.\lib\jcl-over-slf4j-1.7.25.jar;E:\NIFI\nifi-1.7.1\.\lib\jetty-schemas-3.1.jar;E:\NIFI\nifi-1.7.1\.\lib\jul-to-slf4j-1.7.25.jar;E:\NIFI\nifi-1.7.1\.\lib\log4j-over-slf4j-1.7.25.jar;E:\NIFI\nifi-1.7.1\.\lib\logback-classic-1.2.3.jar;E:\NIFI\nifi-1.7.1\.\lib\logback-core-1.2.3.jar;E:\NIFI\nifi-1.7.1\.\lib\nifi-api-1.7.1.jar;E:\NIFI\nifi-1.7.1\.\lib\nifi-framework-api-1.7.1.jar;E:\NIFI\nifi-1.7.1\.\lib\nifi-nar-utils-1.7.1.jar;E:\NIFI\nifi-1.7.1\.\lib\nifi-properties-1.7.1.jar;E:\NIFI\nifi-1.7.1\.\lib\nifi-runtime-1.7.1.jar;E:\NIFI\nifi-1.7.1\.\lib\slf4j-api-1.7.25.jar -Dorg.apache.jasper.compiler.disablejsr199=true -Xmx512m -Xms512m -Djavax.security.auth.useSubjectCredsOnly=true -Djava.security.egd=file:/dev/urandom -Dsun.net.http.allowRestrictedHeaders=true -Djava.net.preferIPv4Stack=true -Djava.awt.headless=true -Djava.protocol.handler.pkgs=sun.net.www.protocol -XX:+UseG1GC -Dnifi.properties.file.path=E:\NIFI\nifi-1.7.1\.\conf\nifi.properties -Dnifi.bootstrap.listen.port=52107 -Dapp=NiFi -Dorg.apache.nifi.bootstrap.config.log.dir=E:\NIFI\nifi-1.7.1\bin\..\\logs --add-modules=java.xml.bind org.apache.nifi.NiFi 
2018-10-18 18:50:54,678 WARN [main] org.apache.nifi.bootstrap.Command Failed to set permissions so that only the owner can read pid file E:\NIFI\nifi-1.7.1\bin\..\run\nifi.pid; this may allows others to have access to the key needed to communicate with NiFi. Permissions should be changed so that only the owner can read this file
2018-10-18 18:50:54,715 WARN [main] org.apache.nifi.bootstrap.Command Failed to set permissions so that only the owner can read status file E:\NIFI\nifi-1.7.1\bin\..\run\nifi.status; this may allows others to have access to the key needed to communicate with NiFi. Permissions should be changed so that only the owner can read this file
2018-10-18 18:50:54,739 INFO [main] org.apache.nifi.bootstrap.Command Launched Apache NiFi with Process ID 13264
2018-10-18 18:50:54,917 INFO [NiFi logging handler] org.apache.nifi.StdOut Error occurred during initialization of boot layer
2018-10-18 18:50:54,918 INFO [NiFi logging handler] org.apache.nifi.StdOut java.lang.module.FindException: Module java.xml.bind not found
2018-10-18 18:50:55,755 INFO [main] org.apache.nifi.bootstrap.RunNiFi NiFi never started. Will not restart NiFi

regards

1 ACCEPTED SOLUTION

Accepted Solutions

Re: unable to install nifi with java 11

Super Guru

As of today, there is only support for JDK 8 and JDK9

https://cwiki.apache.org/confluence/display/NIFI/Release+Notes#ReleaseNotes-Version1.7.1

JDK 11 is coming.

But not today. It will not work.

View solution in original post

2 REPLIES 2

Re: unable to install nifi with java 11

Super Guru

you need to use JDK 8

Re: unable to install nifi with java 11

Super Guru

As of today, there is only support for JDK 8 and JDK9

https://cwiki.apache.org/confluence/display/NIFI/Release+Notes#ReleaseNotes-Version1.7.1

JDK 11 is coming.

But not today. It will not work.

View solution in original post