Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

unable to setup ambari-server using mysql server

Solved Go to solution
Highlighted

unable to setup ambari-server using mysql server

New Contributor

Hi All,

using MySql server to setup ambari server, followed below link to create a username, password, and database for ambari https://docs.hortonworks.com/HDPDocuments/Ambari-2.7.1.0/administering-ambari/content/amb_using_amba...

while ambari-setup, i got below issue: Enter Database Password (bigdata): Invalid characters in password. Use only alphanumeric or _ or - characters

i tried to change the password of mysql database, but got below issue: CREATE USER 'ambari'@'%' IDENTIFIED BY 'bigdata123456'; ERROR 1819 (HY000): Your password does not satisfy the current policy requirements

I find that there is conflict in accepting the password.

Please suggest.

Thanks in Advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: unable to setup ambari-server using mysql server

Super Mentor

@Amit Mishra

Are you using MySQL 8.x?

In MySQL 8.0.4, thevalidate_password plugin was re-implemented as the validate_password component.

https://dev.mysql.com/doc/refman/8.0/en/validate-password.html

So please try using the password something like "Bigdata@123456"

It depends on what kind of policy is added to your MySQL:

The policies implement increasingly strict password tests. The following descriptions refer to default parameter values, which can be modified by changing the appropriate system variables.

.

3 REPLIES 3

Re: unable to setup ambari-server using mysql server

Super Mentor

@Amit Mishra

Are you using MySQL 8.x?

In MySQL 8.0.4, thevalidate_password plugin was re-implemented as the validate_password component.

https://dev.mysql.com/doc/refman/8.0/en/validate-password.html

So please try using the password something like "Bigdata@123456"

It depends on what kind of policy is added to your MySQL:

The policies implement increasingly strict password tests. The following descriptions refer to default parameter values, which can be modified by changing the appropriate system variables.

.

Re: unable to setup ambari-server using mysql server

Super Mentor

@Amit Mishra

Additionally the following blog will give some idea in setting the password restriction policies:

https://gsuartana.wordpress.com/2016/08/18/mysql-error-1819-hy000-your-password-does-not-satisfy-the...

Please check what is the policy set on your DB:

# mysql -u root -p
Enter Password: <DB_ROOT_PASSWORD><br>

mysql> use mysql;
mysql> SHOW VARIABLES LIKE 'validate_password%';
+--------------------------------------+--------+
| Variable_name                        | Value  |
+--------------------------------------+--------+
| validate_password_check_user_name    | OFF    |
| validate_password_dictionary_file    |        |
| validate_password_length             | 8      |
| validate_password_mixed_case_count   | 1      |
| validate_password_number_count       | 1      |
| validate_password_policy             | MEDIUM |
| validate_password_special_char_count | 1      |
+--------------------------------------+--------+<br>

.

You can release the restrictions on passwords by setting some global varialbles like:

# SET GLOBAL validate_password_length = 5;
# SET GLOBAL validate_password_number_count = 0;
# SET GLOBAL validate_password_mixed_case_count = 0;
# SET GLOBAL validate_password_special_char_count = 0;

Re: unable to setup ambari-server using mysql server

Super Mentor

@Amit Mishra

Are you able to login to the DB now?

I see your new thread: https://community.hortonworks.com/questions/225768/issue-while-executing-sql-script-ambari-ddl-mysql...

So if this issue is resolved then please mark it as Closed by clicking on "Accept" button.