Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

unable to start smarsense activity analyzer

Solved Go to solution

unable to start smarsense activity analyzer

I am trying to start SmartSense activity analyzer but it is getting fail and logs are also not available for the same.

but I cat activity-analyzer.out and below is error :

nohup: failed to run command ‘/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64/bin/java’: No such file or directory

I have checked java_home and it is : /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64/jre

and cat /etc/smartsense-activity/conf/activity.ini :

[java] home = /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64/jre

then why in activity-analyzer.out this error is coming ?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: unable to start smarsense activity analyzer

Super Mentor

@Anurag Mishra

If you will make changes to the "" script manually then that is not right because upon restart via Ambari Server , it will be replaced with the default JAVA_HOME setting that ambari server is setting.

export JAVA_HOME={{java_home}}

So please make changes via ambari to make it permanently reflected.

Ambari UI --> SmartSense --> Configs --> Advanced --> Advanced activity-env --> activity-env.sh (Edit the "JAVA_HOME" here)

Replace the following:

 export JAVA_HOME={{java_home}}


With:

 export JAVA_HOME=/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64/jre

.

Please check your other hosts if the PATH exists? And check if other processes on the other hosts are using the JRE that you wanted to use or the JDK home that is mentioned in the ambari.properties? (usually the {{java_home}} is taken what is set in the ambari.properties if you do not explicitly make changes to it.)

# ls -l /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64/bin/java
# ls -l /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64/jre/bin/java

.

# grep 'java.home' /etc/ambari-server/conf/ambari.properties
java.home=/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64

.

https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.0.0/bk_ambari-administration/content/ch_changin...

3 REPLIES 3

Re: unable to start smarsense activity analyzer

Super Mentor

@Anurag Mishra

If you will make changes to the "" script manually then that is not right because upon restart via Ambari Server , it will be replaced with the default JAVA_HOME setting that ambari server is setting.

export JAVA_HOME={{java_home}}

So please make changes via ambari to make it permanently reflected.

Ambari UI --> SmartSense --> Configs --> Advanced --> Advanced activity-env --> activity-env.sh (Edit the "JAVA_HOME" here)

Replace the following:

 export JAVA_HOME={{java_home}}


With:

 export JAVA_HOME=/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64/jre

.

Please check your other hosts if the PATH exists? And check if other processes on the other hosts are using the JRE that you wanted to use or the JDK home that is mentioned in the ambari.properties? (usually the {{java_home}} is taken what is set in the ambari.properties if you do not explicitly make changes to it.)

# ls -l /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64/bin/java
# ls -l /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64/jre/bin/java

.

# grep 'java.home' /etc/ambari-server/conf/ambari.properties
java.home=/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.151-1.b12.el7_4.x86_64

.

https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.0.0/bk_ambari-administration/content/ch_changin...

Re: unable to start smarsense activity analyzer

it is starting thanks

Highlighted

Re: unable to start smarsense activity analyzer

New Contributor

Nice explanation @Jay Kumar SenSharma