Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

[unixODBC][Hortonworks][ThriftExtension] (6) Error occurred while contacting server: SSL_connect: error code: 0. This could be because you are trying to establish a SSL connection to a server that does not have SSL enabled. ODBC general error.

Highlighted

[unixODBC][Hortonworks][ThriftExtension] (6) Error occurred while contacting server: SSL_connect: error code: 0. This could be because you are trying to establish a SSL connection to a server that does not have SSL enabled. ODBC general error.

New Contributor

Hi HCC,

I'm working with a customer to help them connect to hive using ODBC and all was working well until recently, the Admins reconfigured Knox to require only TLSv1.2. Since then, the connection to Knox is failing as follows:

echo "show databases" | isql -v -d, Knox [S1000][unixODBC][Hortonworks][ThriftExtension] (6) Error occurred while contacting server: SSL_connect: error code: 0. This could be because you are trying to establish a SSL connection to a server that does not have SSL enabled. [ISQL]ERROR: Could not SQLConnect Here is the /etc/odbc.ini file:

[Knox]

HiveServerType=2 Driver =/usr/lib/hive/lib/native/Linux-amd64-64/libhortonworkshiveodbc64.so Host=xxxxx.xxx PORT=8443 UID=xxxxx PWD=xxxxxxx AuthMech=3 Schema=default SSL=1 TrustedCerts=/somepath/certificate.cer HTTPPath=gateway/default/hive ThriftTransport=2 UseNativeQuery=1 CAIssuedCertNamesMismatch=1

Any ideas, how to configure the Client to use TLSv1.2?

2 REPLIES 2

Re: [unixODBC][Hortonworks][ThriftExtension] (6) Error occurred while contacting server: SSL_connect: error code: 0. This could be because you are trying to establish a SSL connection to a server that does not have SSL enabled. ODBC general error.

Guru

Hello @Reza Khan,

Please check if :

1. you are connecting to HiveServer2 over http (i.e. HS2 is running in http mode instead of binary)

2. you have import Knox server's SSL certificate into your truststore (I can see /somepath/certificate.cer, yet you should cross check by listing the certificate content)

3. you are able to connect to HS2 using beeline with the connection string like this:

beeline> !connect jdbc:hive2://<knox-server-fqdn>:8443/;ssl=true;sslTrustStore=/tmp/knox-truststore.jks;trustStorePassword=hadoop;transportMode=http;httpPath=gateway/default/hive

Please paste more output of above command here so that we can understand the issue better and help you out further.

Hope this helps !

Re: [unixODBC][Hortonworks][ThriftExtension] (6) Error occurred while contacting server: SSL_connect: error code: 0. This could be because you are trying to establish a SSL connection to a server that does not have SSL enabled. ODBC general error.

New Contributor

Hi @Vipin Rathor,

Thanks for the answer. After some more digging, we saw that Simba fixed a problem with TLS 1.2 on Hive ODBC driver version 2.1.7:

http://cdn.simba.com/products/Hive/doc/Simba_Hive_ODBC_ReleaseNotes.txt

After installing the 2.1.7 ODBC driver, we retried the connection and everything was working.

Thanks for your support.

Reza