Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

user hive/host1 is not allowed to impersonate sentry/host2

avatar
Rising Star

Hello,

 

In my kerberized and Sentry-protected CDH, I started getting the following errors on hive metastore:

 

Caused by: org.apache.hadoop.security.authorize.AuthorizationException: 
User: hive/[email protected] is not allowed to 
impersonate sentry/[email protected]

In core-site.xml I have:

 

hadoop.proxyuser.hive.groups=*
hadoop.proxyuser.hive.users=*

The error started after I was playing around with LDAP integration, though I rollback my configurations to the previous no-LDAP state. I am trying to figure out what I missed.

1 ACCEPTED SOLUTION

avatar
Rising Star

core-site.xml had empty values not *.

 

No issue.

View solution in original post

1 REPLY 1

avatar
Rising Star

core-site.xml had empty values not *.

 

No issue.