Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

what I do if sqoop is not installed but ambari showed it is installed?

Solved Go to solution
Highlighted

what I do if sqoop is not installed but ambari showed it is installed?

Contributor

as we can see, the sqoop is linked to /usr/hdp/2.3.4.0-3485/sqoop, but under /usr/hdp/2.3.4.0-3485, there is no sqoop directory exist, that means sqoop is not installed. however, at ambari, it showed sqoop and all others are installed. what can I do? manually install sqoop is option here if install HDP by ambari, so what can I do from here???

lrwxrwxrwx 1 root root 27 Feb 5 16:20 spark-thriftserver -> /usr/hdp/2.3.4.0-3485/spark

lrwxrwxrwx 1 root root 27 Feb 5 16:20 sqoop-client -> /usr/hdp/2.3.4.0-3485/sqoop

lrwxrwxrwx 1 root root 27 Feb 5 16:20 sqoop-server -> /usr/hdp/2.3.4.0-3485/sqoop

any one can give me a clue on this? I have many tools like sqoop, not installed but showed they were installed on ambari.

thank you for your help.

Robin

1 ACCEPTED SOLUTION

Accepted Solutions

Re: what I do if sqoop is not installed but ambari showed it is installed?

@Robin Dong

Sqoop is client tool. You can login to server and type sqoop

That's sym link to original install directory

9 REPLIES 9

Re: what I do if sqoop is not installed but ambari showed it is installed?

@Robin Dong

Sqoop is client tool. You can login to server and type sqoop

That's sym link to original install directory

Re: what I do if sqoop is not installed but ambari showed it is installed?

There is no start and stop as its client tool

Re: what I do if sqoop is not installed but ambari showed it is installed?

@Robin Dong Hi Robin, You need to install client tools in your node. You can use ambari to install client tools.

Re: what I do if sqoop is not installed but ambari showed it is installed?

You can click add and install client tools

2233-screen-shot-2016-02-17-at-14946-pm.png

Re: what I do if sqoop is not installed but ambari showed it is installed?

Contributor

@neeraj this is what I did on server:

1. su - sqoop --- ok, I am sqoop user now

2. [sqoop@avechdmq1 ~]$ sqoop

-bash: sqoop: command not found

3. I think the sqoop_home is not set and no where to find ./bin to run this 'sqoop', so set it up.

so the link to /usr/hdp/2.3.4.0-3485 dont have sqoop directory is the reason not able to start sqoop.

4. I need to know how fix it if no manually install sqoop is impossible.

last time after could not start sqoop on ambari, I run the command you provided,

grant all privileges on *.* to 'hive'@'avechdmq1.ae.ge.com' identified by 'hivepassword' with grant option;

I am able to start sqoop and all others like pig, tez on ambari, somehow, it changed back now and still not able to start sqoop.

Please help us on this issue, and many others tools have the same link problem. so we can fix them all if this one fixed.

thank you Neeraj.

Re: what I do if sqoop is not installed but ambari showed it is installed?

Contributor

yes, I run the install clients drop down, it showed sqoop is already installed, actually I was not able to run 'sqoop' command and find there is no sqoop directory under /usr/hdp/2.3.4.0-3485/ which all other tools listed (installed) here.

1. install sqoop by ambari is not possible in my case now

2. only thing I worried is if manually install sqoop, pig, tez etc which not work in ambari, can ambari still manage it? no problem?

thanks,

Robin

Re: what I do if sqoop is not installed but ambari showed it is installed?

@Robin Dong You can install sqoop , pig and tez manually...The only thing is that it wont show up in ambari.

Re: what I do if sqoop is not installed but ambari showed it is installed?

Mentor

@Robin Dong in Ambari, go to the host you want sqoop to run from and in the "install clients" drop down, choose install sqoop client. When that completes, go to services page and click refresh clients. Once that completes, you should be able to execute sqoop command.

Re: what I do if sqoop is not installed but ambari showed it is installed?

Explorer

I run into the same problem, where the Ambari says it's installed, but the sqoop directory is not there on the data nodes.

I am running in a cluster, but it should be the same for sandbox.

The current answer does not address this, but the only way to fix this is to uninstall the sqoop client, and re-install it with Ambari.

Unfortunately, current web UI does not allow uninstall of clients.

Fortunately, you can do it through API calls.

Command Syntax is follows:

URL=https://${AMBARI_HOST}/api/v1/clusters/${CLUSTER_NAME}/hosts/${HOST_FQDN}/host_components/SQOOP
curl -k -u admin:admin -H "X-Requested-By:ambari" -i -X DELETE $URL

After that, you can re-install the sqoop client from the Web UI.

Don't have an account?
Coming from Hortonworks? Activate your account here