Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

what's the latest hive-jdbc version supported in HDP 2.6

Solved Go to solution
Highlighted

what's the latest hive-jdbc version supported in HDP 2.6

Contributor

I tried the latest I find in maven repo - but it didn't work. the only version I got working is hive-jdbc-2.0.0

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: what's the latest hive-jdbc version supported in HDP 2.6

@Yair Ogen,

I did a find for hive-jdbc jars and got the below result. Check if any of the paths exist in your setup

/usr/hdp/2.6.2.0-205/spark2/jars/hive-jdbc-1.21.2.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/hive/lib/hive-jdbc.jar

/usr/hdp/2.6.2.0-205/hive/lib/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/hive/jdbc/hive-jdbc-1.2.1000.2.6.2.0-205-standalone.jar

/usr/hdp/2.6.2.0-205/hive2/lib/hive-jdbc-2.1.0.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/hive2/lib/hive-jdbc.jar

/usr/hdp/2.6.2.0-205/hive2/jdbc/hive-jdbc-2.1.0.2.6.2.0-205-standalone.jar

/usr/hdp/2.6.2.0-205/oozie/share/lib/hive2/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/oozie/libserver/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/oozie/libtools/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/zeppelin/interpreter/jdbc/hive-jdbc-1.2.1000.2.6.2.0-205.jar

Thanks,

Aditya

View solution in original post

9 REPLIES 9
Highlighted

Re: what's the latest hive-jdbc version supported in HDP 2.6

@Yair Ogen

Have you tried the Hive-JDBC available on Hortonworks Add-ons download page ?

https://hortonworks.com/downloads/#addons

Highlighted

Re: what's the latest hive-jdbc version supported in HDP 2.6

Contributor

Thanks. Is this is for simba specifically?

My app is a jdbc based app - and I get the jars using maven and just set the driver in config and expect the code to just work.

From the zip for jdbc 4.1 not clear which version of hive-jdbc is used?

For example this zip uses the HS1Driver while I thought I should use: org.apache.hive.jdbc.HiveDriver

Highlighted

Re: what's the latest hive-jdbc version supported in HDP 2.6

@Yair Ogen,

You can find a jdbc jar under ( /usr/hdp/current/hive-client/jdbc) folder.

Thanks,

Aditya

Re: what's the latest hive-jdbc version supported in HDP 2.6

Contributor

In the hive node I don't have a jdbc folder there:

This is what I have:

drwxr-xr-x  7 root root      4096 Sep 27 13:31 ./
drwxr-xr-x 35 root root      4096 Sep 27 15:16 ../
drwxr-xr-x  3 root root      4096 Sep 27 13:28 bin/
lrwxrwxrwx  1 root root        23 Sep 27 13:31 conf -> /etc/hive/2.6.2.0-205/0/
drwxr-xr-x  3 root root      4096 Sep 27 13:28 doc/
-rw-r--r--  1 root root 106117252 Aug 26 12:31 hive.tar.gz
drwxr-xr-x  5 root root     12288 Sep 27 15:25 lib/
drwxr-xr-x  2 root root      4096 Sep 27 13:28 man/
drwxr-xr-x  3 root root      4096 Sep 27 13:28 scripts/



Highlighted

Re: what's the latest hive-jdbc version supported in HDP 2.6

@Yair Ogen,

I did a find for hive-jdbc jars and got the below result. Check if any of the paths exist in your setup.

/usr/hdp/2.6.2.0-205/spark2/jars/hive-jdbc-1.21.2.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/hive/lib/hive-jdbc.jar

/usr/hdp/2.6.2.0-205/hive/lib/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/hive/jdbc/hive-jdbc-1.2.1000.2.6.2.0-205-standalone.jar

/usr/hdp/2.6.2.0-205/hive2/lib/hive-jdbc-2.1.0.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/hive2/lib/hive-jdbc.jar

/usr/hdp/2.6.2.0-205/hive2/jdbc/hive-jdbc-2.1.0.2.6.2.0-205-standalone.jar

/usr/hdp/2.6.2.0-205/oozie/share/lib/hive2/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/oozie/libserver/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/oozie/libtools/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/zeppelin/interpreter/jdbc/hive-jdbc-1.2.1000.2.6.2.0-205.jar 

Thanks,

Aditya

Highlighted

Re: what's the latest hive-jdbc version supported in HDP 2.6

@Yair Ogen,

Did this help you. Can you please accept the answer if it worked for you. That will help the community to find out answers quickly

Highlighted

Re: what's the latest hive-jdbc version supported in HDP 2.6

Contributor

the comment helped not the original answer - but I can't mark a comment with 'accept'

Highlighted

Re: what's the latest hive-jdbc version supported in HDP 2.6

@Yair Ogen,

I wrote the comment as a separate answer. Can you please accept that.

Thanks,

Aditya

Highlighted

Re: what's the latest hive-jdbc version supported in HDP 2.6

@Yair Ogen,

I did a find for hive-jdbc jars and got the below result. Check if any of the paths exist in your setup

/usr/hdp/2.6.2.0-205/spark2/jars/hive-jdbc-1.21.2.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/hive/lib/hive-jdbc.jar

/usr/hdp/2.6.2.0-205/hive/lib/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/hive/jdbc/hive-jdbc-1.2.1000.2.6.2.0-205-standalone.jar

/usr/hdp/2.6.2.0-205/hive2/lib/hive-jdbc-2.1.0.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/hive2/lib/hive-jdbc.jar

/usr/hdp/2.6.2.0-205/hive2/jdbc/hive-jdbc-2.1.0.2.6.2.0-205-standalone.jar

/usr/hdp/2.6.2.0-205/oozie/share/lib/hive2/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/oozie/libserver/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/oozie/libtools/hive-jdbc-1.2.1000.2.6.2.0-205.jar

/usr/hdp/2.6.2.0-205/zeppelin/interpreter/jdbc/hive-jdbc-1.2.1000.2.6.2.0-205.jar

Thanks,

Aditya

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here