Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
08-18-2023
06:48 AM
- last edited on
04-20-2026
11:49 PM
by
GrazittiAPI
Hi,
We are getting an error when initializing the zk Failover Controller here the error below:
WARNING: HADOOP_ZKFC_OPTS has been replaced by HDFS_ZKFC_OPTS. Using value of HADOOP_ZKFC_OPTS.
log4j:ERROR Could not instantiate class [com.cloudera.cmf.eventcatcher.client.logs.ExceptionForwarderAppender].
java.lang.ClassNotFoundException: com.cloudera.cmf.eventcatcher.client.logs.ExceptionForwarderAppender
at java.net.URLClassLoader.findClass(URLClassLoader.java:387)
at java.lang.ClassLoader.loadClass(ClassLoader.java:418)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352)
at java.lang.ClassLoader.loadClass(ClassLoader.java:351)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:264)
at org.apache.log4j.helpers.Loader.loadClass(Loader.java:198)
at org.apache.log4j.helpers.OptionConverter.instantiateByClassName(OptionConverter.java:327)
at org.apache.log4j.helpers.OptionConverter.instantiateByKey(OptionConverter.java:124)
at org.apache.log4j.PropertyConfigurator.parseAppender(PropertyConfigurator.java:785)
at org.apache.log4j.PropertyConfigurator.parseCategory(PropertyConfigurator.java:768)
at org.apache.log4j.PropertyConfigurator.configureRootCategory(PropertyConfigurator.java:648)
at org.apache.log4j.PropertyConfigurator.doConfigure(PropertyConfigurator.java:514)
at org.apache.log4j.PropertyConfigurator.doConfigure(PropertyConfigurator.java:580)
at org.apache.log4j.helpers.OptionConverter.selectAndConfigure(OptionConverter.java:526)
at org.apache.log4j.LogManager.<clinit>(LogManager.java:127)
at org.slf4j.impl.Log4jLoggerFactory.<init>(Log4jLoggerFactory.java:66)
at org.slf4j.impl.StaticLoggerBinder.<init>(StaticLoggerBinder.java:72)
at org.slf4j.impl.StaticLoggerBinder.<clinit>(StaticLoggerBinder.java:45)
at org.slf4j.LoggerFactory.bind(LoggerFactory.java:150)
at org.slf4j.LoggerFactory.performInitialization(LoggerFactory.java:124)
at org.slf4j.LoggerFactory.getILoggerFactory(LoggerFactory.java:417)
at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:362)
at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:388)
at org.apache.hadoop.ha.ZKFailoverController.<clinit>(ZKFailoverController.java:65)
log4j:ERROR Could not instantiate appender named "EventCatcher".
Any idea ?
Regards
Created 08-22-2023 02:28 AM
Unfortunetly this error message was blocking the ZK Failover Controller, so I solved this issue by deleting all Zookeeper data and disabled Kerberos authentifcation and then I started zkFailover controller and I re enabled the Kerberos authentication on Zookeeper.
Created 08-18-2023 09:18 AM
The ERROR message indicates a particular logger class is not available. Usually logger errors wouldn't fail the actual action. Can you clarify what command/action you triggered from CM Role action and in CM whether the command is reported as successful or failed?
A screenshot of the actual failure could be helpful to understand this better.
Created 08-21-2023 10:10 AM
@Yasine Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. If you are still experiencing the issue, can you provide the information @venkatsambath has requested? Thanks.
Regards,
Diana Torres,Created 08-22-2023 02:28 AM
Unfortunetly this error message was blocking the ZK Failover Controller, so I solved this issue by deleting all Zookeeper data and disabled Kerberos authentifcation and then I started zkFailover controller and I re enabled the Kerberos authentication on Zookeeper.