Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

zookeeper having problem after enabling kerberos on cluster

avatar
Expert Contributor

hello cloudera community

 

we are having a problem with zookeeper on cdp after enabling kerberos on the cluster

 

zookeeper instances are healthy (status green), but the general status of zookeeper shows the message:

 

Canary test of client connection to ZooKeeper and execution of basic operations succeeded though a session could not be established with one or more servers

 

yagoaparecidoti_0-1665753645995.png

 

how can we solve this problem?

 

1 ACCEPTED SOLUTION

avatar
Expert Contributor

I managed to solve.

 

canary timeouts have been changed:

 

ZooKeeper Canary Connection Timeout = 30s
ZooKeeper Canary Session Timeout = 1m
ZooKeeper Canary Operation Timeout = 30s

 

with that, the error no longer presented and the status is healthy 100%

View solution in original post

1 REPLY 1

avatar
Expert Contributor

I managed to solve.

 

canary timeouts have been changed:

 

ZooKeeper Canary Connection Timeout = 30s
ZooKeeper Canary Session Timeout = 1m
ZooKeeper Canary Operation Timeout = 30s

 

with that, the error no longer presented and the status is healthy 100%