Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

What's New @ Cloudera

Find the latest Cloudera product news
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

[ANNOUNCE] New Impala JDBC Driver Released

avatar
Rising Star

We are pleased to announce the release of Impala JDBC v2.5.43.  The release has the following fixes:

 

 

Resolved Issues in Impala JDBC 2.5.43

  • When a parameter is bound to a BigDecimal Value, the driver rounds off the value incorrectly.
  • In some cases, the driver incorrectly returns the following error: “Unable to obtain fetch semaphore in time. Fetch thread might have died unexpectedly”.
  • Driver fails to connect through Kerberos when using a ticket cache with an IBM JVM
  • In some cases, the driver fails to execute batched insert operations using prepared statements that are written in Impala syntax.
  • In some cases, the driver fails to execute batched update operations.
  • Driver removes comments from queries when the UseNativeQuery property is set to 1.

 

Getting Started with the Cloudera Driver

 

As always, we welcome your feedback. Please send your comments and suggestions to the user group of through our community forums. You can also file bugs through our external Jira projects on issues.cloudera.org.