Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

What's New @ Cloudera

Find the latest Cloudera product news
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

[ANNOUNCE] New Impala JDBC Driver Released

avatar
Rising Star

We are pleased to announce the release of Impala JDBC v2.5.42.  The release has the following fixes and enhancements:

 

Resolved Issues in Impala JDBC 2.5.42

  • AllowSelfSignedCerts does not disable SSL. This issue has been resolved. Now, when the AllowSelfSignedCerts property is set to 1, SSL verification is disabled. The driver does not verify the server certificate against the trust store, and does not verify if the server's host name matches the CN or Subject Alternative Names in the server certificate.

  • System does not display message for authentication failure.

  • The com.cloudera.commons.codec.binary.Base64 class does not resolve to the correct dependency.

  • If a connection fails due to there being no information available from the server, a generic system message is shown: “Error setting/closing session: null”. This been resolved, the driver now shows the appropriate connection error message in this scenario.

 

Getting Started with the Cloudera Driver

 

As always, we welcome your feedback. Please send your comments and suggestions to the user group of through our community forums. You can also file bugs through our external Jira projects on issues.cloudera.org.