Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

What's New @ Cloudera

Find the latest Cloudera product news
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

[ANNOUNCE] New Impala ODBC Driver Released

avatar
Rising Star

We are pleased to announce the release of Impala ODBC v2.5.42.  The release has the following fixes and enhancements:


Enhancements and New Features in Impala ODBC 2.5.42

  • [00097802] Backward compatibility added for Database connection property. When configuring your connection on a non-Windows machine or through a connection string, you can now use either the Schema or Database connection property to specify the name of the database schema for the connection. Prior to this update, support for the Database connection property had been removed.


Resolved Issues in Impala ODBC 2.5.42

  • [00097666] Driver returns incorrect error code for when the Impala session times out and the auto-reconnection feature is disabled. This issue has been resolved. Before, the driver incorrectly returned a generic error code (SQL state HY000). The driver now returns SQL state 08S01 instead.

  • In some cases, the driver fails to authenticate the connection through Kerberos.

  • In certain scenarios, during query execution the system message "Error creating temporary swap file name" may be displayed.


Getting Started with the Cloudera Driver


As always, we welcome your feedback. Please send your comments and suggestions to the user group of through our community forums. You can also file bugs through our external Jira projects on issues.cloudera.org.