Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

What's New @ Cloudera

Find the latest Cloudera product news
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Announcing: Cloudera Enterprise 5.4.9

avatar
Super Collaborator

Dear CDH, Cloudera Manager, and Cloudera Navigator users,

We are pleased to announce the release of Cloudera Enterprise 5.4.9 (CDH 5.4.9, Cloudera Manager 5.4.9, Cloudera Navigator 2.3.9, and Key Trustee Server 5.4.9).  

This release fixes key bugs and includes the following.

  • CDH fixes for the following issues:
    • Apache Commons Collections Deserialization Vulnerability, described in TSB - 98
    • Enable using a proxy server to connect to S3a
    • Improve diagnostics information for HttpPutFailedException
    • Fix precondition failures from NameNodeEditLogRoller while saving namespace
    • Improve clearing stale state of Java serialization
    • Checkpointing failure caused by shared KerberosAuthenticator
    • Encryption zone on root not loaded from fsimage after NN restart
    • Exception on HBaseSerDe.serialize binary field
    • Analysis exception when a binary operator contains an IN operator with values
    • Connection idle time 1 second is too short and the connection is closed too quickly by the ChoreService
    • Added resource path is sent to cluster as an empty string when externally removed
    • Make MAX_PAGE_HEADER_SIZE configurable

For a full list of upstream JIRAs fixed in CDH 5.4.9, see the issues fixed section of the Release Notes.

  • Cloudera Manager fixes for the following issues:
    • Apache Commons Collections Deserialization Vulnerability, described in TSB - 98
    • Job History Server retaining logs in secure clusters
    • Snapshot policies with names with special characters not handled as expected
    • Updating the Hive NameNode location multiple times could lead to data corruption
    • Kafka MirrorMaker fails to start due to missing settings
    • Cloudera Manager dry-run replication history shows unexpected values

For full list of issues fixed in Cloudera Manager 5.4.9, see the issues fixed section of the Release Notes.

  • Cloudera Navigator 2.3.9 fixes for the following issues:
    • Apache Commons Collections Deserialization Vulnerability, described in TSB - 98
  • Key Trustee Server 5.4.9 fixes the following issues:
    • Cannot register a client with Key Trustee Server after registering GPG public key

We look forward to you trying it out, using the information below:

 

As always, we are happy to hear your feedback. Please send your comments and suggestions to the user group or through our community forums. You can also file bugs through our external JIRA projects on issues.cloudera.org.