Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 04-18-2017 11:29 AM
Steps Followed ==>
-All Environment steps in place
-Agent installed successfully new node thru Ambari url, if I try to install manually in host server it worked fine no issue found.
Error reported ==>
Host Status
Message
test1.cluster.com 100%
Failures encountered
test5.cluster.com 100%
Failures encountered
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 118, in run_action
provider_action()
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 45, in action_install
self.install_package(package_name, self.resource.use_repos, self.resource.skip_repos)
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py", line 49, in install_package
shell.checked_call(cmd, sudo=True, logoutput=self.get_logoutput())
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner
result = function(command, **kwargs)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92, in checked_call
tries=tries, try_sleep=try_sleep)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper
result = _call(command, **kwargs_copy)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call
raise Fail(err_msg)
resource_management.core.exceptions.Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install 'hadoop_2_3_*'' returned 1. Error: Package: hadoop_2_3_0_0_2557-2.7.1.2.3.0.0-2557.el6.x86_64 (HDP-2.3)
Requires: nc
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest2017-04-17 22:37:02,946 - Modifying user hdfs
2017-04-17 22:37:02,967 - Directory['/etc/hadoop'] {'mode': 0755}
2017-04-17 22:37:02,967 - Creating directory Directory['/etc/hadoop']
2017-04-17 22:37:03,028 - Repository['HDP-2.3'] {'base_url': 'http://192.168.0.100/HDP/centos6/2.x/updates/2.3.0.0', 'action': ['create'], 'components': ['HDP', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'HDP', 'mirror_list': None}
2017-04-17 22:37:03,075 - File['/etc/yum.repos.d/HDP.repo'] {'content': InlineTemplate(...)}
2017-04-17 22:37:03,076 - Writing File['/etc/yum.repos.d/HDP.repo'] because it doesn't exist
2017-04-17 22:37:03,076 - Repository['HDP-UTILS-1.1.0.20'] {'base_url': 'http://192.168.0.100/HDP-UTILS-1.1.0.20/repos/centos6', 'action': ['create'], 'components': ['HDP-UTILS', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'HDP-UTILS', 'mirror_list': None}
2017-04-17 22:37:03,079 - File['/etc/yum.repos.d/HDP-UTILS.repo'] {'content': InlineTemplate(...)}
2017-04-17 22:37:03,080 - Writing File['/etc/yum.repos.d/HDP-UTILS.repo'] because it doesn't exist
2017-04-17 22:37:03,080 - Package['unzip'] {}
2017-04-17 22:37:03,270 - Skipping installation of existing package unzip
2017-04-17 22:37:03,270 - Package['curl'] {}
2017-04-17 22:37:03,283 - Skipping installation of existing package curl
2017-04-17 22:37:03,284 - Package['hdp-select'] {}
2017-04-17 22:37:03,296 - Installing package hdp-select ('/usr/bin/yum -d 0 -e 0 -y install hdp-select')
2017-04-17 22:37:06,411 - Package['rpcbind'] {}
2017-04-17 22:37:06,499 - Skipping installation of existing package rpcbind
2017-04-17 22:37:06,499 - Package['hadoop_2_3_*'] {}
2017-04-17 22:37:06,512 - Installing package hadoop_2_3_* ('/usr/bin/yum -d 0 -e 0 -y install 'hadoop_2_3_*'')Will appreciate, if any one direct me to move further.
Thanks you,
Created 04-21-2017 04:37 AM
--It required/touch depended package during the installation of package, after setting up/mount the CentOS iso file on repo server it worked fine with-out any issue.
Thank You..
Created 04-21-2017 04:37 AM
--It required/touch depended package during the installation of package, after setting up/mount the CentOS iso file on repo server it worked fine with-out any issue.
Thank You..