Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 04-07-2017 08:54 AM - edited 09-16-2022 04:25 AM
Getting following error when hive batch sql is triggered via oozie. Works fine when run from edge nod.
HS2 may be unavailable, check server status
Error: org.apache.thrift.transport.TTransportException: java.net.SocketException: Broken pipe (state=08S01,code=0)
Closing: 0: jdbc:hive2://node:10000/hive_instance
HS2 may be unavailable, check server status
Error: Error while cleaning up the server resources (state=,code=0)
Intercepting System.exit(2)
Failing Oozie Launcher, Main class [org.apache.oozie.action.hadoop.Hive2Main], exit code [2]
Created 04-21-2017 03:10 AM
Issue ssems to be resolved, once our admin found out the reason of hiveserver2 restarting frequently.
Created 04-09-2017 03:16 AM
Created 04-10-2017 02:56 PM
Created 04-10-2017 03:32 PM
Actually it is different,in order to mask details i have pasted it as jdbc:hive2://node:10000/hive_instance.
hive-site.xml was added at <job-xml> hive2 action as well in the <file>. Batch sql fails after some of the queries in it being executed succesfully.
I am using hive2 as action.
Created 04-10-2017 03:42 PM
Created 04-21-2017 03:10 AM
Issue ssems to be resolved, once our admin found out the reason of hiveserver2 restarting frequently.