Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-10-2017 11:34 AM
Hi All,
While enabling ambari hive view (unsecured hadoop cluster) - as hive user - getting error
Service 'hiveserver' check failed: Cannot connect to hive
I have disabled 'Run as end user instead of Hive user' on HIVE Config and proxy user hive.users and hosts are set to *
pls suggest if there is some way to fix it.
Service 'hiveserver' check failed: java.lang.Exception: Cannot connect to hive java.lang.Exception: Cannot connect to hive at org.apache.ambari.view.hive2.actor.message.job.ExecutionFailed.<init>(ExecutionFailed.java:28) at org.apache.ambari.view.hive2.actor.JdbcConnector.notifyConnectFailure(JdbcConnector.java:385) at org.apache.ambari.view.hive2.actor.JdbcConnector.connect(JdbcConnector.java:422) at org.apache.ambari.view.hive2.actor.JdbcConnector.handleNonLifecycleMessage(JdbcConnector.java:179) at org.apache.ambari.view.hive2.actor.JdbcConnector.handleMessage(JdbcConnector.java:171) at org.apache.ambari.view.hive2.actor.HiveActor.onReceive(HiveActor.java:38) at akka.actor.UntypedActor$anonfun$receive$1.applyOrElse(UntypedActor.scala:167) at akka.actor.Actor$class.aroundReceive(Actor.scala:467) at akka.actor.UntypedActor.aroundReceive(UntypedActor.scala:97) at akka.actor.ActorCell.receiveMessage(ActorCell.scala:516) at akka.actor.ActorCell.invoke(ActorCell.scala:487)
Thanks,
Avijeet
Created 05-10-2017 03:45 PM
@Avijeet Dash Could you please attach a screenshot of your hive view configuration page?
Created 05-10-2017 01:22 PM
Confirm HiveServer is running. Can also try restarting the service via Ambari
Created 05-10-2017 01:45 PM
Hi @Scott Shaw, hive server 2 is running file, i can reach by beeline, hive etc. This is happening in 2 hdp2.5 clusters, same issue.
Created 05-10-2017 02:11 PM
@Avijeet Dash Double-check the jdbc connection for HiveServer2 JDBC URL in the view definition. I've also had luck by creating a new Hive view instance.
Created 05-10-2017 02:34 PM
@ScottShaw no luck, is using hive user OK, or setting up some other user is better?
Created 05-10-2017 02:37 PM
@Avijeet Dash most likely it is using the account you log into Ambari with. You can try using a different account but to me the errors don't indicate a permissions issue.
Created 05-10-2017 02:43 PM
@Scott Shaw yeah it simply says cannot connect - I tried localhost, 127.0.01, hostname...same error.
Created 05-10-2017 03:45 PM
@Avijeet Dash Could you please attach a screenshot of your hive view configuration page?
Created on 05-11-2017 06:26 AM - edited 08-17-2019 06:22 PM
@Vaisakh Sundaram pls find attached, I had to hide the host names, but hive2 url is correct, I checked with beeline.
Created 05-11-2017 01:30 PM
As I remember I had problems with Hive View 1.5. Could you try using Hive View version 1.0?