Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-08-2016 10:26 AM
Hi,
I am installing Ambari on my server (Oracle Linux 7.2) and I've got couple of issues. In the last step I can't install services, because of errors listed below. Hadoop repo needs packages like nc, redhat-lsb or psmisc. The most strange thing is that on the other cluster where Ambari was installed I can't find packages like that. So why installation package requires them now?
How can I solve this problem? Is it about proxy or OS?
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call
raise Fail(err_msg)
resource_management.core.exceptions.Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install 'hadoop_2_4_*-yarn'' returned 1. Error: Package: hadoop_2_4_0_0_169-2.7.1.2.4.0.0-169.el6.x86_64 (HDP-2.4)
Requires: nc
Error: Package: hadoop_2_4_0_0_169-2.7.1.2.4.0.0-169.el6.x86_64 (HDP-2.4)
Requires: redhat-lsb
Error: Package: hadoop_2_4_0_0_169-2.7.1.2.4.0.0-169.el6.x86_64 (HDP-2.4)
Requires: psmisc
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Created 07-12-2016 11:58 AM
I enabled a repos and installed all of packages manually.
Thanks for your help.
Created 07-08-2016 11:38 AM
Is the other cluster on same OS level? Did you try installing these packages from RHEL repo? Try getting them installed manually, most likely you need to enable a repo and then price with install
Created 07-08-2016 12:19 PM
Can you try running 'yum update -y' on the host and retry the service install?
Created 07-12-2016 11:58 AM
I enabled a repos and installed all of packages manually.
Thanks for your help.
Created 02-12-2018 09:04 AM
I am getting a similar error
resource_management.core.exceptions.ExecutionFailed: Execution of '/usr/bin/yum -d 0 -e 0 -y install accumulo_2_6_0_3_8' returned 1. Error: Package: hadoop_2_6_0_3_8-2.7.3.2.6.0.3-8.x86_64 (HDP-2.6-repo-5)
Requires: nc
which repo did you enable exactly?
Created 02-13-2018 08:37 AM
You should log in to your machine as a root user and install nc package. I don't know which OS you are using, but if it is CentOS you should execute this command (on every host machine):
yum install nc
Created 02-15-2018 11:27 AM
thanks, had to adjust my repo and yum install nc worked just fine.
much appreciated