Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-23-2017 12:02 AM
Enviroment:
Centos 7 + Ambari 2.2.1
Error Log:
[root@master ~]# wget http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.2.1.0/ambari.repo --2017-03-23 00:36:19-- http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.2.1.0/ambari.repo Resolving public-repo-1.hortonworks.com (public-repo-1.hortonworks.com)... 52.85.47.94, 52.85.47.81, 52.85.47.121, ... Connecting to public-repo-1.hortonworks.com (public-repo-1.hortonworks.com)|52.85.47.94|:80... connected. HTTP request sent, awaiting response... 200 OK Length: 287 [binary/octet-stream] Saving to: ‘ambari.repo’ 100%[======================================>] 287 --.-K/s in 0s 2017-03-23 00:36:19 (42.7 MB/s) - ‘ambari.repo’ saved [287/287] [root@master ~]# cp ambari.repo /etc/yum.repos.d [root@master ~]# yum install ambari‐serverLoaded plugins: fastestmirror, langpacks Updates-ambari-2.2.1.0 | 2.9 kB 00:00 Loading mirror speeds from cached hostfile * base: sunsite.rediris.es * extras: sunsite.rediris.es * updates: sunsite.rediris.es Error: Nothing to do [root@master ~]# ambari-server setup bash: ambari-server: command not found... [root@master ~]#
Yum info:
[root@master ~]# yum repolist Loaded plugins: fastestmirror, langpacks Loading mirror speeds from cached hostfile * base: sunsite.rediris.es * extras: sunsite.rediris.es * updates: sunsite.rediris.es repo id repo name status Updates-ambari-2.2.1.0 ambari-2.2.1.0 - Updates 7 base/7/x86_64 CentOS-7 - Base 9,363 extras/7/x86_64 CentOS-7 - Extras 311 updates/7/x86_64 CentOS-7 - Updates 1,111 repolist: 10,792 [root@master ~]#
[root@master ~]# cat /etc/yum.repos.d/ambari.repo #VERSION_NUMBER=2.2.1.0-161 [Updates-ambari-2.2.1.0] name=ambari-2.2.1.0 - Updates baseurl=http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.2.1.0 gpgcheck=1 gpgkey=http://public-repo-1.hortonworks.com/ambari/centos7/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins enabled=1 priority=1 [root@master ~]# ^C [root@master ~]#
Please I need help...
How I can resolve the issue "Error: Nothing to do" ?
Created 03-23-2017 12:39 AM
Before installing ambari-server can you please share & verify the output of the following commands
# wget -nv http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.2.1.0/ambari.repo -O /etc/yum.repos.d/ambari.repo # yum clean all # yum info ambari-server # ambari-server --version # yum install ambari-server -y
In your yum output i see that it is using some cached entry as following:
Loading mirror speeds from cached hostfile * base: sunsite.rediris.es * extras: sunsite.rediris.es * updates: sunsite.rediris.es Error: Nothing to do
Hence it is better to clear the yum cache first, you can use the following command.
# yum clean all
If you are using any Http Proxy at your end then in the "~/.bash_profile" profile we can add the following: (here replace the "proxyHostName:3128" with proxy host and port number)
export http_proxy=http://proxyHostName:3128/
export https_proxy=${http_proxy}
export ftp_proxy=${http_proxy}Also please see: http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.1.0/bk_ambari_reference_guide/content/_how_to_se...
Created 03-23-2017 12:39 AM
Before installing ambari-server can you please share & verify the output of the following commands
# wget -nv http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.2.1.0/ambari.repo -O /etc/yum.repos.d/ambari.repo # yum clean all # yum info ambari-server # ambari-server --version # yum install ambari-server -y
In your yum output i see that it is using some cached entry as following:
Loading mirror speeds from cached hostfile * base: sunsite.rediris.es * extras: sunsite.rediris.es * updates: sunsite.rediris.es Error: Nothing to do
Hence it is better to clear the yum cache first, you can use the following command.
# yum clean all
If you are using any Http Proxy at your end then in the "~/.bash_profile" profile we can add the following: (here replace the "proxyHostName:3128" with proxy host and port number)
export http_proxy=http://proxyHostName:3128/
export https_proxy=${http_proxy}
export ftp_proxy=${http_proxy}Also please see: http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.1.0/bk_ambari_reference_guide/content/_how_to_se...
Created 03-23-2017 12:26 PM
Hi Jay,
Clean the yum cache and install with the option "-y" has been the solution.
Thank you very much
Created 03-24-2017 05:50 PM
# yum clean all # yum install ambari-server -y
Should solve this 🙂