Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-30-2017 08:01 AM
I just installed Atlas 0.8 on an HDP 2.6.0 cluster, which was recently upgraded from HDP 2.3.2 and Kerberized. Yet Atlas 0.8's Metadata Server wouldn't start, with these error messages:
KeeperErrorCode = NoNode for /infra-solr/collections/vertex_index org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /infra-solr/collections/vertex_index at org.apache.zookeeper.KeeperException.create(KeeperException.java:111) at org.apache.zookeeper.KeeperException.create(KeeperException.java:51) at org.apache.zookeeper.ZooKeeper.getACL(ZooKeeper.java:1330) at org.apache.ambari.logsearch.solr.util.AclUtils.setRecursivelyOn(AclUtils.java:76) at org.apache.ambari.logsearch.solr.util.AclUtils.setRecursivelyOn(AclUtils.java:70) at org.apache.ambari.logsearch.solr.commands.SecureZNodeZkCommand.executeZkCommand(SecureZNodeZkCommand.java:45) at org.apache.ambari.logsearch.solr.commands.SecureZNodeZkCommand.executeZkCommand(SecureZNodeZkCommand.java:32) at org.apache.ambari.logsearch.solr.commands.AbstractZookeeperRetryCommand.createAndProcessRequest(AbstractZookeeperRetryCommand.java:38) at org.apache.ambari.logsearch.solr.commands.AbstractRetryCommand.retry(AbstractRetryCommand.java:45) at org.apache.ambari.logsearch.solr.commands.AbstractRetryCommand.run(AbstractRetryCommand.java:40) at org.apache.ambari.logsearch.solr.AmbariSolrCloudClient.secureZnode(AmbariSolrCloudClient.java:177) at org.apache.ambari.logsearch.solr.AmbariSolrCloudCLI.main(AmbariSolrCloudCLI.java:522)
The zookeeper-client indicates that the znode /infra-solr/configs/atlas_configs does exist, yet none of the Atlas's intended collections (namely, vertex_index, edge_index, and fulltext_index) were created.
I attempted to delete the znode /infra-solr/configs/atlas_configs and start from scratch, but I was blocked by an authentication error, as shown below:
rmr /infra-solr/configs/atlas_configs
Authentication is not valid : /infra-solr/configs/atlas_configs/solrconfig.xml
So, how am I going to get out of this?
For reference, here is the sequence of operations performed on the cluster:
<1> Starting Point: HDP 2.3.2 managed by Ambari Server 2.1.2.
<2> Upgraded Ambari Server to 2.5.2.0.
<3> Installed Ambari Infra (including Solr).
<4> Deleted Atlas 0.5.0.
<5> Implemented Kerberos.
<6> Upgraded to HDP 2.6.0.
<7> Installed Atlas 0.8.0.
Now, is it possible that the znode /infra-solr/configs/atlas_configs was actually created by Atlas 0.5.0 when the cluster was still on HDP 2.3.2? (Which is probably why I cannot authenticate and delete it?)
Many thanks!
Created 12-11-2017 10:24 PM
In fact, this is the combined effect of two issues:
<1> The atlas.war file was not extracted properly during the Atlas installation. So, manually do so, as detailed here:
https://community.hortonworks.com/questions/104751/index.html
<2> The bug AMBARI-18368 caused a number of Atlas configuration files to be absent from their intended locations. The instructions to address this issue is here:
https://issues.apache.org/jira/browse/AMBARI-18368
Now, Atlas is up, finally.
Created 12-11-2017 10:24 PM
In fact, this is the combined effect of two issues:
<1> The atlas.war file was not extracted properly during the Atlas installation. So, manually do so, as detailed here:
https://community.hortonworks.com/questions/104751/index.html
<2> The bug AMBARI-18368 caused a number of Atlas configuration files to be absent from their intended locations. The instructions to address this issue is here:
https://issues.apache.org/jira/browse/AMBARI-18368
Now, Atlas is up, finally.