Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Atlas UI not available : Service Unavailable

avatar
New Member

Hi,

I have installed HDP 2.5 on Azure. All my services are OK on the Ambari interface but when I try to access to the Atlas Dashboard, I encounter following error :

11473-capture-decran-2017-01-17-a-155259.png

Looking at /var/log/atlas/application.log :

Error injecting constructor, org.apache.atlas.repository.RepositoryException: org.apache.solr.client.solrj.impl.HttpSolrClient$RemoteSolrException: Error from server at http://10.0.0.5:8886/solr: Can not find the specified config set: vertex_index

Do you have any idea ?

Thanks for your help.

Regards, Olivier

1 ACCEPTED SOLUTION

avatar

See if you are running into similar issue mentioned here https://issues.apache.org/jira/browse/AMBARI-18368

View solution in original post

4 REPLIES 4

avatar
Expert Contributor

Looks like the Solr index didn't get created properly or is having issues. Can you share your application.properties file ?

avatar

See if you are running into similar issue mentioned here https://issues.apache.org/jira/browse/AMBARI-18368

avatar
New Member

Hi Milind,

Than you for your answer. Unfortunately, I have already tried this...

Moreover, I have following error on Solr:

Collection: vertex_index operation: create failed:org.apache.solr.common.SolrException: Can not find the specified config set: vertex_index
	at org.apache.solr.cloud.OverseerCollectionMessageHandler.createCollection(OverseerCollectionMessageHandler.java:1904)
	at org.apache.solr.cloud.OverseerCollectionMessageHandler.processMessage(OverseerCollectionMessageHandler.java:221)
	at org.apache.solr.cloud.OverseerTaskProcessor$Runner.run(OverseerTaskProcessor.java:437)
	at org.apache.solr.common.util.ExecutorUtil$MDCAwareThreadPoolExecutor$1.run(ExecutorUtil.java:231)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Any idea ?

Regards,

Olivier

avatar
New Member

Sorry it worked !!!

I just had to change the command :

chown atlas:hadoop /etc/atlas/conf/solr/*

to

chown -R atlas:hadoop /etc/atlas/conf/solr/*

Thanks a lot for your help