Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-15-2018 10:16 AM
On a HDP 2.6.3 sandbox I'm creating a couple of HDFS path entities in bulk.
This is the JSON file I've used:
{
"entities": [
{
"typeName": "hdfs_path",
"attributes": {
"path": "/user/dmaster/electionresults",
"qualifiedName": "hdfs://sandbox.hortonworks.com:8020/user/dmaster/electionresults",
"name": "/user/dmaster/electionresults"
},
"classification": [],
"status": "ACTIVE"
},
{
"typeName": "hdfs_path",
"attributes": {
"path": "/user/dmaster/nyse",
"qualifiedName": "hdfs://sandbox.hortonworks.com:8020/user/dmaster/nyse",
"name": "/user/dmaster/nyse"
},
"classification": [],
"status": "ACTIVE"
},
{
"typeName": "hdfs_path",
"attributes": {
"path": "/user/dmaster/lca",
"qualifiedName": "hdfs://sandbox.hortonworks.com:8020/user/dmaster/lca",
"name": "/user/dmaster/lca"
},
"classification": [],
"status": "ACTIVE"
}
],
"referredEntities": {}
}
And this is the Atlas REST API call I've ran:
curl -X POST -d @atlas_create_entities_bulk.json -u holger_gov:holger_gov -H 'Content-Type: application/json; charset=UTF-8' http://sandbox.hortonworks.com:21000/api/atlas/v2/entity/bulk
This resulted after a while in this error:
{"errorCode":"ATLAS-500-00-007","errorMessage":"Failed to notify for change CREATE"}The HDFS path entities have been created (quite quickly I saw) and they seem okay. Should I be worried about this error message?
Here are the details on the created entities, retrieved with a /v2/search/dsl API call:
{
"typeName": "hdfs_path",
"attributes": {
"owner": null,
"qualifiedName": "hdfs://sandbox.hortonworks.com:8020/user/dmaster/electionresults",
"name": "/user/dmaster/electionresults",
"description": null
},
"guid": "b81c8a22-0346-4261-8cb7-1b0be91ee134",
"status": "ACTIVE",
"displayText": "/user/dmaster/electionresults",
"classificationNames": []
},
{
"typeName": "hdfs_path",
"attributes": {
"owner": null,
"qualifiedName": "hdfs://sandbox.hortonworks.com:8020/user/dmaster/nyse",
"name": "/user/dmaster/nyse",
"description": null
},
"guid": "26b81bb8-4dcb-48d0-b0d4-37df38fff1b2",
"status": "ACTIVE",
"displayText": "/user/dmaster/nyse",
"classificationNames": []
},
{
"typeName": "hdfs_path",
"attributes": {
"owner": null,
"qualifiedName": "hdfs://sandbox.hortonworks.com:8020/user/dmaster/lca",
"name": "/user/dmaster/lca",
"description": null
},
"guid": "e4789fba-67ef-4195-bc3f-afb1623985f8",
"status": "ACTIVE",
"displayText": "/user/dmaster/lca",
"classificationNames": []
}
Created 02-20-2018 06:47 AM
The HDFS path entities have been created (quite quickly I saw) and they seem okay. Should I be worried about this error message?
Its issue if other application like RANGER is going to consume the Atlas hdfs entities created from ATLAS_ENTITIES Kafka topic, otherwise you can ignore the error message.
Created 02-20-2018 06:47 AM
The HDFS path entities have been created (quite quickly I saw) and they seem okay. Should I be worried about this error message?
Its issue if other application like RANGER is going to consume the Atlas hdfs entities created from ATLAS_ENTITIES Kafka topic, otherwise you can ignore the error message.
Created 02-28-2018 04:03 PM
It seems these messages only occur on my sandbox environment. On my customers HDP 2.6.3 environment I haven't seen any ATLAS-500-00-007 errors yet.