Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-28-2015 10:23 PM - edited 09-16-2022 02:46 AM
Hi All,
I am facing an issue in BDR.
BDR is configured with a hive replication and it fails in the third step(Importing metadata)
The error message, that I received was "<table name> Table does not match version in metastore."
What could be the problem here?
Thanks in advance
Sebin
Created 10-28-2015 10:28 PM
This error likely occurs because the target hive service already has a version of that table, but with different metadata properties. In order to overwrite it, check/select the "Force Overwrite" option in the hive replication schedule.
How many times do you see this and how many tables are having this error?
Created 10-28-2015 10:28 PM
This error likely occurs because the target hive service already has a version of that table, but with different metadata properties. In order to overwrite it, check/select the "Force Overwrite" option in the hive replication schedule.
How many times do you see this and how many tables are having this error?
Created 10-28-2015 10:30 PM
Created 01-16-2017 09:05 PM
I got the same issue and resolved with using the "Force Overwrite" while Hive replication setup