Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-19-2015 07:15 PM
Hi,
I am running a fresh installed HDP cluster with Kerberos enabled.
I try to connect to Hive using beeline command:
beeline -u jdbc:hive2://deala01876.corp:10000/default;principal=hive/[email protected]
I receive the following error:
scan complete in 5ms Connecting to jdbc:hive2://deala01876.corp:10000/default SLF4J: Class path contains multiple SLF4J bindings. SLF4J: Found binding in [jar:file:/usr/hdp/2.2.4.2-2/hadoop/lib/slf4j-log4j12-1.7.5.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: Found binding in [jar:file:/usr/hdp/2.2.4.2-2/hive/lib/hive-jdbc-0.14.0.2.2.4.2-2-standalone.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings... for an explanation. SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory] Error: Could not open client transport with JDBC Uri: jdbc:hive2://deala01876.corp:10000/default: Peer indicated failure: Unsupported mechanism type PLAIN (state=08S01,code=0) Beeline version 0.14.0.2.2.4.2-2 by Apache Hive 0: jdbc:hive2://deala01876.corp:1 (closed)>
The local user has a valid Kerberos ticket, as well as the hive user on the Hiveserver node.
HiveServer2 authentication is set to "Kerberos", and property "hive.server2.authentication.kerberos.principal" is set to value " hive/[email protected]"
What is going wrong here, what to check further ?
Created 12-21-2015 09:54 AM
@Vipin Rathor , @Neeraj Sabharwal,
it is solved.....and what a stupid cause 😉
The connection can be established if I put quotes around the JDBC URL =>
W999711@DEALA01885:~$ beeline -u "jdbc:hive2://deala01876.corp:10000/default;principal=hive/[email protected]" scan complete in 5ms Connecting to jdbc:hive2://deala01876.corp:10000/default;principal=hive/[email protected] SLF4J: Class path contains multiple SLF4J bindings. SLF4J: Found binding in [jar:file:/usr/hdp/2.2.4.2-2/hadoop/lib/slf4j-log4j12-1.7.5.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: Found binding in [jar:file:/usr/hdp/2.2.4.2-2/hive/lib/hive-jdbc-0.14.0.2.2.4.2-2-standalone.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings. for an explanation. SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory] Connected to: Apache Hive (version 0.14.0.2.2.4.2-2) Driver: Hive JDBC (version 0.14.0.2.2.4.2-2) Transaction isolation: TRANSACTION_REPEATABLE_READ Beeline version 0.14.0.2.2.4.2-2 by Apache Hive 0: jdbc:hive2://deala01876.corp:1>
sorry for causing any confusion 😄
Created 01-10-2016 08:31 AM
try beeline --verbose=true -u "jdbc:hive2://deala01876.corp:10000/default;principal=hive/[email protected]"
Created 01-12-2016 01:36 PM
The one liner :
beeline -u "jdbc:hive2://ip-hive-server-ip separated with hifen>:10000/default;principal=driver-details" -n $USER