Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-23-2017 06:36 AM
Hi Team,
We have multitenant platform , We are using hdp 2.4 with kerborose authentication.
since its multi tenant/multi user platform we ahve different accounts setup per user.
when different users run hive queries such as insert overwrite table XYZ select * from ABC;
then hive by default refers to /tmp as scratchdir to do intermediate data processing .At the end when it tries to move data \
from /tmp to respective EZ for that user lets say /apps/hive/warehouse/<user-ez-dir> it fails with below error Failed with exception
Unable to move source hdfs ://HDPXYZ/tmp/hive/<user_name>/<some encrypted string> to destination hdfs://HDPXYZ/apps/hive/warehouse/<user_ez_dir>.
I know we can set scratchdir while running the script through -hiveconf.
I am interested to know if we can sett somewhere per user basis as we can't set it globally in hive-site.xml as there are multiple users
Created 05-23-2017 01:25 PM
Can you please check the permissions on your warehouse directory and Ranger permissions for the failed users. I think the issue is in your destination and not source.
Created 05-23-2017 01:25 PM
Can you please check the permissions on your warehouse directory and Ranger permissions for the failed users. I think the issue is in your destination and not source.
Created 05-08-2018 09:23 AM
Can you explain in detail as how you solved, facing similar issue now. Thanks in advance.