Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-29-2017 08:14 AM
Hi.
I have reinstalled my cluster (HDP 2.6.0.3 (Ambari 2.5.0.3)) and cannot get hive to work. I removed it from one node and added it to another but it (hiverserver2) still won't start. I get this error:
resource_management.core.exceptions.ExecutionFailed: Execution of '/usr/jdk64/jdk1.8.0_112/bin/java -cp /usr/lib/ambari-agent/DBConnectionVerification.jar:/usr/hdp/current/hive-server2/lib/mysql-connector-java.jar org.apache.ambari.server.DBConnectionVerification 'jdbc:mysql://s1.royble.co.uk/hive?createDatabaseIfNotExist=true' hive [PROTECTED] com.mysql.jdbc.Driver' returned 1. ERROR: Unable to connect to the DB. Please check DB connection properties.java.sql.SQLException: Access denied for user 'hive'@'s2.royble.co.uk' (using password: YES)
I saw this solution, but I do not have the required file on my computer, and I think I am missing lots of Hive stuff, for example there are no hive* folders below usr/hdp . Any idea how I can get Hive installed correctly?
Created 05-29-2017 08:33 AM
This Error "Access denied for user 'hive'@'s2.royble.co.uk' (using password: YES)" itself states that you are entering wrong password for hive user crerated in Mysql.
To solve this Login to mysql
mysql> drop database hive;
And retry the installation of Hive service in ambari.
Created 05-29-2017 08:33 AM
This Error "Access denied for user 'hive'@'s2.royble.co.uk' (using password: YES)" itself states that you are entering wrong password for hive user crerated in Mysql.
To solve this Login to mysql
mysql> drop database hive;
And retry the installation of Hive service in ambari.
Created 06-02-2017 07:20 AM
Created 05-29-2017 08:34 AM
You are getting Access Denied while accessing mysql. So looks like you have node set the PRIVILEGES properly inside the mysql DB.
Please see: https://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-reference/content/using_hive_with...
# mysql -u root -p CREATE USER '<HIVEUSER>'@'localhost' IDENTIFIED BY '<HIVEPASSWORD>'; GRANT ALL PRIVILEGES ON *.* TO '<HIVEUSER>'@'localhost'; CREATE USER '<HIVEUSER>'@'%' IDENTIFIED BY '<HIVEPASSWORD>'; GRANT ALL PRIVILEGES ON *.* TO '<HIVEUSER>'@'%'; CREATE USER '<HIVEUSER>'@'<HIVEMETASTOREFQDN>' IDENTIFIED BY '<HIVEPASSWORD>'; GRANT ALL PRIVILEGES ON *.* TO '<HIVEUSER>'@'<HIVEMETASTOREFQDN>'; FLUSH PRIVILEGES;
.
Created 06-02-2017 07:31 AM
The link that you shared to migrate from Derby to MySQL seems to be too old (2013) and there are many changes and enhancements made in hive.
I do not see "Derby" database in the supported list of Databases in: https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.0/bk_support-matrices/content/ch_matrices-hdp... So if this is your fresh cluster then you should install Hive with the supported databases to avoid the DB issues.
HDP 2.6 Hive Database Requirements
PostgreSQL 9.1.13+, 9.3, 9.4***
MariaDB 10*
MySQL 5.6****
Oracle 11gr2
Oracle 12c**
By default (on RHEL/CentOS/Oracle Linux 6), Ambari installs an instance of MySQL
on the Hive Metastore host. Otherwise, you need to use an existing instance of
PostgreSQL, MySQL or Oracle.
.
Created 06-03-2017 07:49 AM
Thanks. I was getting confused: it was mysql all along.