Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 06-06-2018 12:23 PM - edited 08-17-2019 09:14 PM
when I am trying to start kafka with the following command :
`bin/kafka-server-start.sh config/server.properties`
I am getting this error every time
Cannot open file /opt/kafka_2.11-1.1.0/bin/../logs/kafkaServer-gc.log due to Permission denied. how to fix this ...
Created 06-06-2018 05:48 PM
Hey @Rahul Kumar could you try to run as kafka user? Or root
Created 06-06-2018 05:48 PM
Hey @Rahul Kumar could you try to run as kafka user? Or root
Created 06-07-2018 06:00 AM
Yes, it is working as a root user Thanks @Vinicius Higa Murakami
Created 06-06-2018 08:02 PM
I think @Vinicius Higa Murakami is correct, if you take a closer look you are running as user rahul and probably the log file under logs directory belongs to different user, or you dont have write permissions on it. If you are starting from command line always double check which user you are running with and switch to the appropiate service account.
HTH
Created 06-07-2018 05:59 AM
Yes, it is working as a root user Thanks @Felix Albani