Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Cannot open file /opt/kafka_2.11-1.1.0/bin/../logs/kafkaServer-gc.log due to Permission denied

avatar
New Member

when I am trying to start kafka with the following command :

`bin/kafka-server-start.sh config/server.properties`

I am getting this error every time

Cannot open file /opt/kafka_2.11-1.1.0/bin/../logs/kafkaServer-gc.log due to Permission denied. how to fix this ...

76588-kafka-error.png

1 ACCEPTED SOLUTION

avatar

Hey @Rahul Kumar could you try to run as kafka user? Or root

View solution in original post

4 REPLIES 4

avatar

Hey @Rahul Kumar could you try to run as kafka user? Or root

avatar
New Member

Yes, it is working as a root user Thanks @Vinicius Higa Murakami

avatar

@Rahul Kumar

I think @Vinicius Higa Murakami is correct, if you take a closer look you are running as user rahul and probably the log file under logs directory belongs to different user, or you dont have write permissions on it. If you are starting from command line always double check which user you are running with and switch to the appropiate service account.

HTH

avatar
New Member

Yes, it is working as a root user Thanks @Felix Albani