Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-27-2017 02:32 PM
cloudbreak-shell>cluster create --description "Haoop Pilot" --password D@T@L@K3_2017 --enableKnoxGateway true --stackRepoId HDP-2.6 --stackBaseURL "http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.6.0.3" --stack "HDP" --utilsBaseURL "http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.21/repos/centos7" --utilsRepoId "HDP-UTILS-1.1.0.21" --os RedHat Command failed java.lang.RuntimeException: may not be null
I get the above error message and I can't figure out what parameter I need to add or "may not be null" is there a way to turn on more verbose errors so I can try and understand what's happening?
Created 09-27-2017 02:43 PM
I looked into the cbreak.log and it showed that:
constraintviolation: post.arg1.ambariStackDetails.verify - may not be null
So I guess the error message just needs a little work.
Created 09-27-2017 02:43 PM
I looked into the cbreak.log and it showed that:
constraintviolation: post.arg1.ambariStackDetails.verify - may not be null
So I guess the error message just needs a little work.
Created 09-27-2017 02:46 PM
@Matt Andruff please add --verify=true as parameter and thanks for reporting the issue
Created 09-27-2017 06:55 PM
I did with no real help... but I found what I think it's not happy about:
223501 [Spring Shell] DEBUG org.apache.http.wire - http-outgoing-3 << "me":"HDFS_CLIENT"},{"name":"SQOOP"},{"name":"METRICS_MONITOR"},{"name":"INFRA_SOLR_CLIENT"},{"name":"HBASE_MASTER"},{"name":"TEZ_CLIENT"},{"name":"ATLAS_SERVER"},{"name":"ZOOKEEPER_CLIENT"},{"name":"HCAT"},{"name":"PIG"},{"name":"KAFKA_BROKER"},{"name":"MAPREDUCE2_CLIENT"},{"name":"ATLAS_CLIENT"},{"name":"OOZIE_CLIENT"},{"name":"HBASE_CLIENT"},{"name":"INFRA_SOLR"},{"name":"HIVE_CLIENT"}],"name":"host_group_5","cardinality":"1"}],"Blueprints":{"blueprint_name":"edc-ranger-template","stack_name":"HDP","stack_version":"2.6"}},"description":"","inputs":[],"id":2036,"blueprintName":"edc-ranger-template","hostGroupCount":6,"status":"USER_MANAGED","public":false}[\r][\n]"
223532 [Spring Shell] DEBUG org.apache.http.wire - http-outgoing-3 >> "{"name":"hadoop-pilot-ranger-test3-rg","blueprintId":2036,"blueprint":null,"description":"Haoop Pilot","hostGroups":[{"name":"host_group_3","constraint":{"instanceGroupName":"host_group_3","constraintTemplateName":null,"hostCount":1},"recipeIds":[],"recoveryMode":"MANUAL","recipes":null},{"name":"host_group_6","constraint":{"instanceGroupName":"host_group_6","constraintTemplateName":null,"hostCount":1},"recipeIds":[5],"recoveryMode":"MANUAL","recipes":null},{"name":"host_group_2","constraint":{"instanceGroupName":"host_group_2","constraintTemplateName":null,"hostCount":1},"recipeIds":[],"recoveryMode":"MANUAL","recipes":null},{"name":"host_group_1","constraint":{"instanceGroupName":"host_group_1","constraintTemplateName":null,"hostCount":1},"recipeIds":[],"recoveryMode":"MANUAL","recipes":null},{"name":"host_group_4","constraint":{"instanceGroupName":"host_group_4","constraintTemplateName":null,"hostCount":4},"recipeIds":[],"recoveryMode":"MANUAL","recipes":null},{"name":"host_group_5","constraint":{"instanceGroupName":"host_group_5","constraintTemplateName":null,"hostCount":1},"recipeIds":[],"recoveryMode":"MANUAL","recipes":null}],"emailNeeded":false,"emailTo":null,"gateway":{"enableGateway":true,"path":null,"topologyName":null,"exposedServices":["ALL"],"ssoProvider":null,"signCert":null,"signPub":null,"gatewayType":null,"ssoType":null},"enableSecurity":false,"userName":"admin","password":"D@T@L@K3_2017","kerberos":{"masterKey":null,"admin":null,"password":null,"url":null,"realm":null,"principal":null,"ldapUrl":null,"containerDn":null,"tcpAllowed":false},"ldapRequired":false,"sssdConfigId":null,"sssdConfig":null,"ldapConfigId":null,"ldapConfig":null,"validateBlueprint":false,"ambariStackDetails":{"stack":"HDP","version":null,"os":"RedHat","stackRepoId":"HDP-2.6","stackBaseURL":"http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.6.0.3","utilsRepoId":"HDP-UTILS-1.1.0.21","utilsBaseURL":"http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.21/repos/centos7","verify":true},"ambariRepoDetailsJson":{"version":"2.5.0.3-7","baseUrl":"http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.5.0.3","gpgKeyUrl":"http://public-repo-1.hortonworks.com/ambari/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins"},"rdsConfigIds":[],"ambariDatabaseDetails":null,"rdsConfigJsons":[],"fileSystem":null,"configStrategy":"ALWAYS_APPLY_DONT_OVERRIDE_CUSTOM_VALUES","enableShipyard":false,"blueprintInputs":[],"blueprintCustomProperties":null,"customContainer":null,"customQueue":"default","connectedCluster":null}[\r][\n]"
223568 [Spring Shell] DEBUG org.apache.http.wire - http-outgoing-3 << "{"validationErrors":{"post.arg1.ambariStackDetails.version":"may not be null"}}"
If you read carefully I think it's complaining about "ambariStackDetails":{"stack":"HDP","version":null,"
so how do I set that?
Created 09-27-2017 06:57 PM
nm I eventually got it:
cluster create --version 2.6 --description "Haoop Pilot" --password D@T@L@K3_2017 --enableKnoxGateway true --stackRepoId HDP-2.6 --stackBaseURL "http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.6.0.3" --stack "HDP" --utilsBaseURL "http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.21/repos/centos7" --utilsRepoId "HDP-UTILS-1.1.0.21" --os RedHat --ambariRepoBaseURL http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.5.0.3 --ambariVersion 2.5.0.3-7 --ambariRepoGpgKey http://public-repo-1.hortonworks.com/ambari/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins --verify true Cluster creation started
So I guess just a better error mesasge would be helpful saying that "--version" required.