Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 01-26-2017 02:47 PM - edited 09-16-2022 03:58 AM
I am trying to bootstrap a CDH 5.9.1 cluster with MIT KDC in AWS. The same configuration works without kerberos. The application log didn't show any error. The bootrap command failed as follows:
...
* Enabling Kerberos ............................................................................................................................................................ done
* Calling firstRun on cluster m7test ... done
* Waiting for firstRun on cluster m7test .............................................................................................................................................................. done
* Collecting diagnostic data ................................................................................................................ done
* Cloudera Manager 'First Run' command execution failed: Failed to perform First Run of services. ...
I logged into CM and saw HDFS data nodes all failed to start. DN failed to authenticate with NN.
Created 01-26-2017 07:22 PM
Created 01-26-2017 05:07 PM
NN indicates the authentication failure is due to the following:
2017-01-26 20:04:09,861 INFO org.apache.hadoop.ipc.Server: Socket Reader #1 for port 8022: readAndProcess from client 10.3.1.23 threw e
xception [javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: Failure unspecified at GSS-API level (Mechani
sm level: Encryption type AES256 CTS mode with HMAC SHA1-96 is not supported/enabled)]]
Created 01-26-2017 07:22 PM