Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 11-02-2017 04:10 PM - edited 09-16-2022 05:28 AM
Hi ,
I am able to create the Virtual Machine on Azure, Installed Cloudera Director.
While Deploying the Cloudera Manager , it failed with the Error "Bootstrap Failed" on hint it shows "Insufficient number of instances available after allocation".
Any help is on it is much appreciated...
Below is the Application.log from /var/log/cloudera-director-server
[2017-11-02 18:00:55.798 -0500] INFO [RxIoScheduler-31] - - - - - c.c.d.a.c.p.AzureComputeProvider: Starting to delete VM director-154feaf6-908d-4a5a-a9f5-13aafbd85966 and its resources.
[2017-11-02 18:00:55.798 -0500] INFO [RxIoScheduler-31] - - - - - c.c.d.a.c.p.AzureComputeProvider: Deleting VM director-154feaf6-908d-4a5a-a9f5-13aafbd85966.
[2017-11-02 18:00:55.886 -0500] INFO [RxIoScheduler-31] - - - - - c.c.d.a.c.p.AzureComputeProvider: Successful delete of VM director-154feaf6-908d-4a5a-a9f5-13aafbd85966.
[2017-11-02 18:00:55.886 -0500] INFO [RxIoScheduler-31] - - - - - c.c.d.a.c.p.AzureComputeProvider: Deleting Storage Account 154feaf6.
[2017-11-02 18:00:56.853 -0500] INFO [RxIoScheduler-31] - - - - - c.c.d.a.c.p.AzureComputeProvider: Successful delete of Storage Account 154feaf6.
[2017-11-02 18:00:56.854 -0500] INFO [RxIoScheduler-31] - - - - - c.c.d.a.c.p.AzureComputeProvider: Deleting NIC 154feaf6.
[2017-11-02 18:00:57.248 -0500] INFO [RxIoScheduler-31] - - - - - c.c.d.a.c.p.AzureComputeProvider: Successful delete of NIC 154feaf6.
[2017-11-02 18:00:57.248 -0500] INFO [RxIoScheduler-31] - - - - - c.c.d.a.c.p.AzureComputeProvider: Deleting Public IP 154feaf6.
[2017-11-02 18:01:07.445 -0500] INFO [RxIoScheduler-31] - - - - - c.c.d.a.c.p.AzureComputeProvider: Successful delete of Public IP 154feaf6.
[2017-11-02 18:01:07.445 -0500] INFO [RxIoScheduler-31] - - - - - c.c.d.a.c.p.AzureComputeProvider: Delete of VM director-154feaf6-908d-4a5a-a9f5-13aafbd85966 and its resources took 11 seconds.
[2017-11-02 18:01:14.632 -0500] INFO [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.d.a.c.p.AzureComputeProvider: Create Virtual Machines: it took 42 seconds to create 0 out of 1 VMs with the prefix director from the group with instanceIds of: [154feaf6-908d-4a5a-a9f5-13aafbd85966].
[2017-11-02 18:01:14.632 -0500] INFO [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.d.a.c.p.AzureComputeProvider: Provisioned 0 instances out of 1. minCount is 1.
[2017-11-02 18:01:14.632 -0500] INFO [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.d.a.c.p.AzureComputeProvider: Preparing to delete VMs in Resource Group wopdtestrg. Instance prefix: director. VM Ids: [154feaf6-908d-4a5a-a9f5-13aafbd85966].
[2017-11-02 18:01:14.632 -0500] INFO [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.d.a.c.p.AzureComputeProvider: Finding in Resource Group wopdtestrg with the instance prefix of director the following VMs: [154feaf6-908d-4a5a-a9f5-13aafbd85966].
[2017-11-02 18:01:14.877 -0500] INFO [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.d.a.c.p.AzureComputeProvider: Found the following VMs: [].
[2017-11-02 18:01:14.878 -0500] WARN [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.l.bootstrap.AllocateInstances: Error while attempting to allocate instances for group CM. Attempting to continue.
com.cloudera.launchpad.pipeline.UnrecoverablePipelineError: Failed to create enough instances.
at com.cloudera.launchpad.pluggable.common.ExceptionConditions.propagateWithSuppressedDetails(ExceptionConditions.java:125)
at com.cloudera.launchpad.pluggable.compute.PluggableComputeProvider.allocate(PluggableComputeProvider.java:616)
at com.cloudera.launchpad.pluggable.compute.PluggableComputeProvider.allocateInstancesForTemplate(PluggableComputeProvider.java:545)
at com.cloudera.launchpad.pluggable.compute.PluggableComputeProvider.allocate(PluggableComputeProvider.java:520)
at com.cloudera.launchpad.pluggable.compute.PluggableComputeProvider.allocate(PluggableComputeProvider.java:331)
at com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun.run(AllocateInstances.java:220)
at com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun.run(AllocateInstances.java:196)
at com.cloudera.launchpad.pipeline.job.Job2.runUnchecked(Job2.java:31)
at com.cloudera.launchpad.pipeline.job.Job2$$FastClassBySpringCGLIB$$54178502.invoke(<generated>)
at org.springframework.cglib.proxy.MethodProxy.invoke(MethodProxy.java:204)
at org.springframework.aop.framework.CglibAopProxy$CglibMethodInvocation.invokeJoinpoint(CglibAopProxy.java:721)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:157)
at org.springframework.aop.aspectj.MethodInvocationProceedingJoinPoint.proceed(MethodInvocationProceedingJoinPoint.java:85)
at com.cloudera.launchpad.pipeline.PipelineJobProfiler.profileJobRun(PipelineJobProfiler.java:60)
at sun.reflect.GeneratedMethodAccessor254.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.springframework.aop.aspectj.AbstractAspectJAdvice.invokeAdviceMethodWithGivenArgs(AbstractAspectJAdvice.java:629)
at org.springframework.aop.aspectj.AbstractAspectJAdvice.invokeAdviceMethod(AbstractAspectJAdvice.java:618)
at org.springframework.aop.aspectj.AspectJAroundAdvice.invoke(AspectJAroundAdvice.java:70)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
at org.springframework.aop.interceptor.ExposeInvocationInterceptor.invoke(ExposeInvocationInterceptor.java:92)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
at org.springframework.aop.framework.CglibAopProxy$DynamicAdvisedInterceptor.intercept(CglibAopProxy.java:656)
at com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun$$EnhancerBySpringCGLIB$$edbe32dd.runUnchecked(<generated>)
at com.cloudera.launchpad.pipeline.util.PipelineRunner$JobCallable.call(PipelineRunner.java:201)
at com.cloudera.launchpad.pipeline.util.PipelineRunner$JobCallable.call(PipelineRunner.java:172)
at com.github.rholder.retry.AttemptTimeLimiters$NoAttemptTimeLimit.call(AttemptTimeLimiters.java:78)
at com.github.rholder.retry.Retryer.call(Retryer.java:160)
at com.cloudera.launchpad.pipeline.util.PipelineRunner.attemptMultipleJobExecutionsWithRetries(PipelineRunner.java:135)
at com.cloudera.launchpad.pipeline.DatabasePipelineRunner.doRun(DatabasePipelineRunner.java:199)
at com.cloudera.launchpad.pipeline.DatabasePipelineRunner.run(DatabasePipelineRunner.java:139)
at com.cloudera.launchpad.ExceptionHandlingRunnable.run(ExceptionHandlingRunnable.java:57)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Suppressed: com.cloudera.launchpad.pluggable.common.ExceptionConditions$DetailHolderException: Exception details:
Caused by: com.cloudera.director.spi.v2.model.exception.UnrecoverableProviderException: Failed to create enough instances.
at com.cloudera.director.spi.v2.adapters.v1.ExceptionsAdapter.fromV1(ExceptionsAdapter.java:84)
at com.cloudera.director.spi.v2.adapters.v1.ExceptionsAdapter.fromV1(ExceptionsAdapter.java:51)
at com.cloudera.director.spi.v2.adapters.v1.ComputeProviderAdapter$1.allocate(ComputeProviderAdapter.java:125)
at com.cloudera.director.spi.v2.adapters.v1.ComputeProviderAdapter$1.allocate(ComputeProviderAdapter.java:55)
at com.cloudera.launchpad.pluggable.compute.PluggableComputeProvider.allocate(PluggableComputeProvider.java:614)
... 36 common frames omitted
[2017-11-02 18:01:14.878 -0500] ERROR [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.l.pipeline.util.PipelineRunner: Attempt to execute job failed
com.cloudera.launchpad.pipeline.UnrecoverablePipelineError: Insufficient number of instances available after allocation
at com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun.run(AllocateInstances.java:257)
at com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun.run(AllocateInstances.java:196)
at com.cloudera.launchpad.pipeline.job.Job2.runUnchecked(Job2.java:31)
at com.cloudera.launchpad.pipeline.job.Job2$$FastClassBySpringCGLIB$$54178502.invoke(<generated>)
at org.springframework.cglib.proxy.MethodProxy.invoke(MethodProxy.java:204)
at org.springframework.aop.framework.CglibAopProxy$CglibMethodInvocation.invokeJoinpoint(CglibAopProxy.java:721)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:157)
at org.springframework.aop.aspectj.MethodInvocationProceedingJoinPoint.proceed(MethodInvocationProceedingJoinPoint.java:85)
at com.cloudera.launchpad.pipeline.PipelineJobProfiler.profileJobRun(PipelineJobProfiler.java:60)
at sun.reflect.GeneratedMethodAccessor254.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.springframework.aop.aspectj.AbstractAspectJAdvice.invokeAdviceMethodWithGivenArgs(AbstractAspectJAdvice.java:629)
at org.springframework.aop.aspectj.AbstractAspectJAdvice.invokeAdviceMethod(AbstractAspectJAdvice.java:618)
at org.springframework.aop.aspectj.AspectJAroundAdvice.invoke(AspectJAroundAdvice.java:70)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
at org.springframework.aop.interceptor.ExposeInvocationInterceptor.invoke(ExposeInvocationInterceptor.java:92)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
at org.springframework.aop.framework.CglibAopProxy$DynamicAdvisedInterceptor.intercept(CglibAopProxy.java:656)
at com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun$$EnhancerBySpringCGLIB$$edbe32dd.runUnchecked(<generated>)
at com.cloudera.launchpad.pipeline.util.PipelineRunner$JobCallable.call(PipelineRunner.java:201)
at com.cloudera.launchpad.pipeline.util.PipelineRunner$JobCallable.call(PipelineRunner.java:172)
at com.github.rholder.retry.AttemptTimeLimiters$NoAttemptTimeLimit.call(AttemptTimeLimiters.java:78)
at com.github.rholder.retry.Retryer.call(Retryer.java:160)
at com.cloudera.launchpad.pipeline.util.PipelineRunner.attemptMultipleJobExecutionsWithRetries(PipelineRunner.java:135)
at com.cloudera.launchpad.pipeline.DatabasePipelineRunner.doRun(DatabasePipelineRunner.java:199)
at com.cloudera.launchpad.pipeline.DatabasePipelineRunner.run(DatabasePipelineRunner.java:139)
at com.cloudera.launchpad.ExceptionHandlingRunnable.run(ExceptionHandlingRunnable.java:57)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
[2017-11-02 18:01:14.878 -0500] ERROR [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.l.p.DatabasePipelineRunner: Encountered an unrecoverable error: JobError{jobClassName=com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun, jobArguments=[VirtualInstanceGroup{name='CM', virtualInstances=[VirtualInstance{id='154feaf6-908d-4a5a-a9f5-13aafbd85966', template=InstanceTemplate{name='wopdtestcm', type='STANDARD_DS12_V2', image='cloudera-centos-67-latest', rackId='/default', bootstrapScriptsArePresent=true, config={dataDiskSize=1024, availabilitySet=wopdtestmnavnomd, virtualNetworkResourceGroup=wopdtestrg, hostFqdnSuffix=cdh-cluster.internal, publicIP=Yes, dataDiskCount=5, subnetName=default, virtualNetwork=wopdtestvnet, computeResourceGroup=wopdtestrg, instanceNamePrefix=director, storageAccountType=Premium_LRS, managedDisks=No, useCustomManagedImage=No, networkSecurityGroupResourceGroup=wopdtestrg, networkSecurityGroup=wopdtestnsg}, tags={}, normalizeInstance=true, sshUsername=Optional.absent(), sshHostKeyRetrievalType=NONE}}], serviceTypeToRoleTypes={}, roleTypesConfigs={}, minCount=1}, Environment{name='wopdtestenv', provider=InstanceProviderConfig{type='azure'}, credentials=SshCredentials{username='wopdcduser', hasPassword=false, hasPrivateKey=true, hasPassphrase=false, port=22, hostKeyFingerprint=Optional.absent(), bastionHost=Optional.absent()}}], jobContext=JobContext{callCountAtThisStackLevel=0, pipelineHandle='b59d1ce3-1951-4418-85f5-929955f5c317', callStack=CallStack{items=[Item{className='com.cloudera.launchpad.api.jobs.DefaultBootstrapDeploymentJob', callCount=1}, Item{className='com.cloudera.launchpad.bootstrap.AllocateInstances', callCount=0}], size=2, parent=Optional.absent()}, stackLevel=2}, errorInfo=ErrorInfo{code=INSTANCE_ALLOCATION_FAILURE, properties={minRequiredCount=1, numberOfInstancesAllocated=0, virtualInstanceGroup=CM}, causes=[]}}
com.cloudera.launchpad.pipeline.UnrecoverablePipelineError: Insufficient number of instances available after allocation
at com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun.run(AllocateInstances.java:257)
at com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun.run(AllocateInstances.java:196)
at com.cloudera.launchpad.pipeline.job.Job2.runUnchecked(Job2.java:31)
at com.cloudera.launchpad.pipeline.job.Job2$$FastClassBySpringCGLIB$$54178502.invoke(<generated>)
at org.springframework.cglib.proxy.MethodProxy.invoke(MethodProxy.java:204)
at org.springframework.aop.framework.CglibAopProxy$CglibMethodInvocation.invokeJoinpoint(CglibAopProxy.java:721)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:157)
at org.springframework.aop.aspectj.MethodInvocationProceedingJoinPoint.proceed(MethodInvocationProceedingJoinPoint.java:85)
at com.cloudera.launchpad.pipeline.PipelineJobProfiler.profileJobRun(PipelineJobProfiler.java:60)
at sun.reflect.GeneratedMethodAccessor254.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.springframework.aop.aspectj.AbstractAspectJAdvice.invokeAdviceMethodWithGivenArgs(AbstractAspectJAdvice.java:629)
at org.springframework.aop.aspectj.AbstractAspectJAdvice.invokeAdviceMethod(AbstractAspectJAdvice.java:618)
at org.springframework.aop.aspectj.AspectJAroundAdvice.invoke(AspectJAroundAdvice.java:70)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
at org.springframework.aop.interceptor.ExposeInvocationInterceptor.invoke(ExposeInvocationInterceptor.java:92)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
at org.springframework.aop.framework.CglibAopProxy$DynamicAdvisedInterceptor.intercept(CglibAopProxy.java:656)
at com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun$$EnhancerBySpringCGLIB$$edbe32dd.runUnchecked(<generated>)
at com.cloudera.launchpad.pipeline.util.PipelineRunner$JobCallable.call(PipelineRunner.java:201)
at com.cloudera.launchpad.pipeline.util.PipelineRunner$JobCallable.call(PipelineRunner.java:172)
at com.github.rholder.retry.AttemptTimeLimiters$NoAttemptTimeLimit.call(AttemptTimeLimiters.java:78)
at com.github.rholder.retry.Retryer.call(Retryer.java:160)
at com.cloudera.launchpad.pipeline.util.PipelineRunner.attemptMultipleJobExecutionsWithRetries(PipelineRunner.java:135)
at com.cloudera.launchpad.pipeline.DatabasePipelineRunner.doRun(DatabasePipelineRunner.java:199)
at com.cloudera.launchpad.pipeline.DatabasePipelineRunner.run(DatabasePipelineRunner.java:139)
at com.cloudera.launchpad.ExceptionHandlingRunnable.run(ExceptionHandlingRunnable.java:57)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
[2017-11-02 18:01:14.879 -0500] ERROR [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.l.p.DatabasePipelineRunner: Pipeline 'b59d1ce3-1951-4418-85f5-929955f5c317' failed
at com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun$$EnhancerBySpringCGLIB$$edbe32dd
at com.cloudera.launchpad.bootstrap.AllocateInstances:0
[2017-11-02 18:01:14.891 -0500] INFO [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.l.p.s.PipelineRepositoryService: Pipeline 'b59d1ce3-1951-4418-85f5-929955f5c317': RUNNING -> ERROR
[2017-11-02 18:01:14.911 -0500] INFO [p-929955f5c317-DefaultBootstrapDeploymentJob] 4e7e437e-f090-4cf1-9bae-8bd088992af8 POST /api/v10/environments/wopdtestenv/deployments com.cloudera.launchpad.bootstrap.AllocateInstances$AllocateAndWaitForInstancesToRun - c.c.l.d.DeploymentRepositoryService: Deployment 'wopdtestcm': BOOTSTRAPPING -> BOOTSTRAP_FAILED
[2017-11-02 18:02:25.007 -0500] INFO [task-thread-10] - - - - - c.c.launchpad.task.RefreshClusters: Refreshing Cluster models
[2017-11-02 18:02:25.007 -0500] INFO [task-thread-10] - - - - - c.c.launchpad.task.RefreshClusters: Finished refreshing all pre-existing Cluster models
[2017-11-02 18:02:25.068 -0500] INFO [task-thread-2] - - - - - c.c.l.task.RefreshDeployments: Refreshing pre-existing Deployments
[2017-11-02 18:03:24.944 -0500] INFO [task-thread-3] - - - - - c.c.l.m.r.DeploymentsReporter: Enqueueing all deployments for usage reporting
[2017-11-02 18:03:24.948 -0500] INFO [task-thread-3] - - - - - c.c.l.m.r.DeploymentsReporter: Enqueueing 0 deployments for usage reporting
Created 11-07-2017 02:47 PM
Hi Vivek,
ah, so you can't deploy a HA cluster (3 masters) from the cloudera director UI. there's two ways forward:
1. instead of a HA cluster deploy a non-HA cluster: 1 Master + n workers (as many as you want) + 0 gateway nodes (remove the gateway role in the UI)
2. follow the instructions here for deploying a HA cluster using the Cloudera Director CLI
Since it looks like you're deploying a small cluster right now I would recommend method #1 to deploy a non-HA cluster.
Let me know if that works
Created 11-07-2017 03:46 PM
Hi Jason,
Thanks a lot for your continued prompt Support.
Really Appreciated.
I am able to deploy the Non-HA Cluster for now, which is a POC.
I will take care of HA, when we decide doing a HA POC or move on to Production.
Regards
Created 11-07-2017 03:48 PM
Hi Vivek,
Glad to hear! Feel free to open up another thread if you run into anything else along the way.