Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 01-24-2017 07:53 PM - edited 09-16-2022 08:19 AM
MySQL 5.7 is listed as supported DB version. However, Cloudera Director generates passwords not suitable for 5.7 standard. Application log is shown as follows:
[2017-01-24 22:46:13] INFO [io-thread-38] - ssh:10.3.1.154: [ main] DbProvisioner ERROR Stack Trace:
[2017-01-24 22:46:13] INFO [io-thread-38] - ssh:10.3.1.154: java.sql.SQLException: Your password does not satisfy the current policy requirements
[2017-01-24 22:46:13] INFO [io-thread-38] - ssh:10.3.1.154: at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1078)[mysql-connec
tor-java.jar:]
Created 01-25-2017 06:19 AM
Hello zhuw.bigdata,
This is a known issue with Director's automated generation of passwords for MySQL databases. There is a fix for it included with Director 2.3, which is due to be released soon. In the meantime, you can try adjusting the password validation level in MySQL 5.7 to LOW, instead of the default MEDIUM, and Director's passwords should be accepted.
Director uses ordinary random UUIDs as passwords, and they fail the MEDIUM level of MySQL password validation because they lack an uppercase letter (and may, in very rare cases, lack either a lowercase letter or a number).
Created 01-25-2017 06:19 AM
Hello zhuw.bigdata,
This is a known issue with Director's automated generation of passwords for MySQL databases. There is a fix for it included with Director 2.3, which is due to be released soon. In the meantime, you can try adjusting the password validation level in MySQL 5.7 to LOW, instead of the default MEDIUM, and Director's passwords should be accepted.
Director uses ordinary random UUIDs as passwords, and they fail the MEDIUM level of MySQL password validation because they lack an uppercase letter (and may, in very rare cases, lack either a lowercase letter or a number).
Created 01-25-2017 07:31 AM
Created 04-24-2017 12:11 AM
# cp /etc/my.cnf /etc/my.cnf.default
# vim /etc/my.cnf
--------------------------------
[mysqld]
# Disable password validaion plugin
validate-password=off
--------------------------------
# systemctl restart mysqld