Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-26-2016 01:31 PM
Hi
I am using falcon 0.6.1
When I am trying to submit process or feed I am getting error:
Cluster entity vertex must exist
In case I just restarted falcon server then I can submit process or feed:
[margusja@hadoopnn2 ~]$ falcon entity -submit -type process -file web3.xml
falcon/default/Submit successful (process) sign--web3
But after I deleted process:
[margusja@hadoopnn2 ~]$ falcon entity -delete -type process -name sign--web3
falcon/default/sign--web3(process) removed successfully (KILLED in ENGINE)
And I try to submit again then I am getting:
[margusja@hadoopnn2 ~]$ falcon entity -submit -type process -file web3.xml
ERROR: Bad Request;default/org.apache.falcon.FalconWebException::org.apache.falcon.FalconException: java.lang.RuntimeException: java.lang.IllegalStateException: Cluster entity vertex must exist: Cluster2
and in log:
2016-07-26 16:28:26,873 INFO - [63390@qtp-1536471117-0 - aa4fe6b0-3d10-4fcd-b8fe-d83ee9e6f7b7:] ~ HttpServletRequest RemoteUser is null (Servlets:47)
2016-07-26 16:28:26,873 INFO - [63390@qtp-1536471117-0 - aa4fe6b0-3d10-4fcd-b8fe-d83ee9e6f7b7:] ~ HttpServletRequest user.name param value is margusja (Servlets:53)
2016-07-26 16:28:27,010 INFO - [2138332724@qtp-1536471117-3 - b0cea0a4-efff-48c8-a81f-5c9ffda411a7:] ~ HttpServletRequest RemoteUser is null (Servlets:47)
2016-07-26 16:28:27,011 INFO - [2138332724@qtp-1536471117-3 - b0cea0a4-efff-48c8-a81f-5c9ffda411a7:] ~ HttpServletRequest user.name param value is margusja (Servlets:53)
2016-07-26 16:28:27,358 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:] ~ HttpServletRequest RemoteUser is falcon (Servlets:47)
2016-07-26 16:28:27,359 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Logging in falcon (CurrentUser:65)
2016-07-26 16:28:27,359 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Request from authenticated user: falcon, URL=/api/entities/submit/process, doAs user: null (FalconAuthenticationFilter:185)
2016-07-26 16:28:27,362 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Parsed Entity: sign--web3 (EntityParser:95)
2016-07-26 16:28:27,364 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Parsed Entity: sign--web3 (EntityParser:95)
2016-07-26 16:28:27,381 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Creating FS for the login user falcon, impersonation not required (HadoopClientFactory:191)
2016-07-26 16:28:27,406 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Persisted configuration PROCESS/sign--web3 (ConfigurationStore:371)
2016-07-26 16:28:27,407 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Adding lineage for entity: sign--web3, type: PROCESS (MetadataMappingService:209)
2016-07-26 16:28:27,409 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Adding process entity: sign--web3 (EntityRelationshipGraphBuilder:131)
2016-07-26 16:28:27,465 ERROR - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Illegal State: Cluster entity vertex must exist for Cluster2 (EntityRelationshipGraphBuilder:173)
2016-07-26 16:28:27,476 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Adding process entity: sign--web3 (EntityRelationshipGraphBuilder:131)
2016-07-26 16:28:27,497 ERROR - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Illegal State: Cluster entity vertex must exist for Cluster2 (EntityRelationshipGraphBuilder:173)
2016-07-26 16:28:27,518 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Adding process entity: sign--web3 (EntityRelationshipGraphBuilder:131)
2016-07-26 16:28:27,536 ERROR - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Illegal State: Cluster entity vertex must exist for Cluster2 (EntityRelationshipGraphBuilder:173)
2016-07-26 16:28:27,537 ERROR - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Unable to persist entity object (AbstractEntityManager:198)
org.apache.falcon.FalconException: java.lang.RuntimeException: java.lang.IllegalStateException: Cluster entity vertex must exist: Cluster2
at org.apache.falcon.metadata.MetadataMappingService.onAdd(MetadataMappingService.java:223)
at org.apache.falcon.entity.store.ConfigurationStore.onAdd(ConfigurationStore.java:259)
at org.apache.falcon.entity.store.ConfigurationStore.publish(ConfigurationStore.java:219)
at org.apache.falcon.resource.AbstractEntityManager.submitInternal(AbstractEntityManager.java:414)
at org.apache.falcon.resource.AbstractEntityManager.submit(AbstractEntityManager.java:195)
at org.apache.falcon.resource.ConfigSyncService.submit(ConfigSyncService.java:50)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at org.apache.falcon.resource.channel.IPCChannel.invoke(IPCChannel.java:49)
at org.apache.falcon.resource.proxy.SchedulableEntityManagerProxy$1.doExecute(SchedulableEntityManagerProxy.java:139)
at org.apache.falcon.resource.proxy.SchedulableEntityManagerProxy$EntityProxy.execute(SchedulableEntityManagerProxy.java:577)
at org.apache.falcon.resource.proxy.SchedulableEntityManagerProxy.submit_aroundBody0(SchedulableEntityManagerProxy.java:141)
at org.apache.falcon.resource.proxy.SchedulableEntityManagerProxy$AjcClosure1.run(SchedulableEntityManagerProxy.java:1)
at org.aspectj.runtime.reflect.JoinPointImpl.proceed(JoinPointImpl.java:149)
at org.apache.falcon.aspect.AbstractFalconAspect.logAroundMonitored(AbstractFalconAspect.java:51)
at org.apache.falcon.resource.proxy.SchedulableEntityManagerProxy.submit(SchedulableEntityManagerProxy.java:119)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at com.sun.jersey.spi.container.JavaMethodInvokerFactory$1.invoke(JavaMethodInvokerFactory.java:60)
at com.sun.jersey.server.impl.model.method.dispatch.AbstractResourceMethodDispatchProvider$TypeOutInvoker._dispatch(AbstractResourceMethodDispatchProvider.java:185)
at com.sun.jersey.server.impl.model.method.dispatch.ResourceJavaMethodDispatcher.dispatch(ResourceJavaMethodDispatcher.java:75)
at com.sun.jersey.server.impl.uri.rules.HttpMethodRule.accept(HttpMethodRule.java:288)
at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
...
Caused by: java.lang.RuntimeException: java.lang.IllegalStateException: Cluster entity vertex must exist: Cluster2
at com.tinkerpop.blueprints.util.TransactionRetryStrategy$AbstractRetryStrategy.execute(TransactionRetryStrategy.java:176)
at com.tinkerpop.blueprints.util.TransactionRetryHelper.use(TransactionRetryHelper.java:115)
at com.tinkerpop.blueprints.util.TransactionRetryHelper.exponentialBackoff(TransactionRetryHelper.java:94)
at org.apache.falcon.metadata.MetadataMappingService.onAdd(MetadataMappingService.java:211)
... 64 more
Caused by: java.lang.IllegalStateException: Cluster entity vertex must exist: Cluster2
at org.apache.falcon.metadata.EntityRelationshipGraphBuilder.addRelationToCluster(EntityRelationshipGraphBuilder.java:174)
at org.apache.falcon.metadata.EntityRelationshipGraphBuilder.addProcessEntity(EntityRelationshipGraphBuilder.java:140)
at org.apache.falcon.metadata.EntityRelationshipGraphBuilder.addEntity(EntityRelationshipGraphBuilder.java:62)
at org.apache.falcon.metadata.MetadataMappingService$1.execute(MetadataMappingService.java:215)
at org.apache.falcon.metadata.MetadataMappingService$1.execute(MetadataMappingService.java:212)
at com.tinkerpop.blueprints.util.TransactionRetryStrategy$AbstractRetryStrategy.execute(TransactionRetryStrategy.java:146)
... 67 more
2016-07-26 16:28:27,541 ERROR - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Action failed: Bad Request
Error: java.lang.RuntimeException: java.lang.IllegalStateException: Cluster entity vertex must exist: Cluster2 (FalconWebException:83)
2016-07-26 16:28:27,542 ERROR - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ Action failed: Bad Request
Error: default/org.apache.falcon.FalconWebException::org.apache.falcon.FalconException: java.lang.RuntimeException: java.lang.IllegalStateException: Cluster entity vertex must exist: Cluster2
(FalconWebException:83)
2016-07-26 16:28:27,542 INFO - [2138332724@qtp-1536471117-3 - 1e1fa678-4426-4398-b942-348c5742cc68:falcon:POST//entities/submit/process] ~ {Action:submit, Dimensions:{colo=NULL, entityType=process}, Status: FAILED, Time-taken:182944401 ns} (METRIC:38)
~
Any hints?
-- Margus (margusja) Roo <a href="http://margus.roo.ee">http://margus.roo.ee</a> skype: margusja +372 51 48 780
Created 07-11-2017 12:21 AM
To resolve this issue - Please remove org.apache.falcon.metadata.MetadataMappingService out from *.application.services in falcon startup.properties and restart falcon server
Created 07-26-2016 01:44 PM
Did you submit the cluster entity. Here is the step to do.
$FALCON_HOME/bin/falcon entity -submit -type cluster -file /cluster/definition.xml
Created 07-26-2016 01:45 PM
Yes cluster is there. I can submit feeds and processes just after falcon restart but not later.
Created 07-27-2016 12:04 PM
This issue is getting tracked on the following Apache Falcon JIRA : https://issues.apache.org/jira/browse/FALCON-1955
Created 07-11-2017 12:21 AM
To resolve this issue - Please remove org.apache.falcon.metadata.MetadataMappingService out from *.application.services in falcon startup.properties and restart falcon server