Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Configure Cloudera Manager with external database: AWS RDS MySQL failed

avatar
Expert Contributor

Since AWS RDS MySQL instance doesn’t grant the initial DB user  the real ‘root’ privileges, I need specific instructions on AWS RDS setup. 

 

I can’t run  the following command to create a temp user.  (https://www.cloudera.com/documentation/enterprise/latest/topics/cm_ig_installing_configuring_dbs.htm...😞

mysql> grant all on *.* to 'temp'@'%' identified by 'temp' with grant option;

 

I had to modify with the following:

mysql> grant all on `%`.* to 'temp'@'%' identified by 'temp' with grant option;

 

[ec2-user@ip-x ~]$  sudo /usr/share/cmf/schema/scm_prepare_database.sh mysql -h $myDB-endpoints -utemp -ptemp --scm-host ip-x.us-west-1.compute.internal scm scm scm

JAVA_HOME=/usr/java/jdk1.8.0_121

Verifying that we can write to /etc/cloudera-scm-server

Creating SCM configuration file in /etc/cloudera-scm-server

Executing:  /usr/java/jdk1.8.0_121/bin/java -cp /usr/share/java/mysql-connector-java.jar:/usr/share/java/oracle-connector-java.jar:/usr/share/cmf/schema/../lib/* com.cloudera.enterprise.dbutil.DbCommandExecutor /etc/cloudera-scm-server/db.properties com.cloudera.cmf.db.

[                          main] DbCommandExecutor              INFO  Unable to login using supplied username/password.

[                          main] DbCommandExecutor              ERROR Error when connecting to database.

java.sql.SQLException: Access denied for user 'scm'@'myIP'  (using password: YES)

                                                at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:964)[mysql-connector-java.jar:5.1.41]

                                                at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3973)[mysql-connector-java.jar:5.1.41]

                                                at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3909)[mysql-connector-java.jar:5.1.41]

                                                at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:873)[mysql-connector-java.jar:5.1.41]

                                                at com.mysql.jdbc.MysqlIO.proceedHandshakeWithPluggableAuthentication(MysqlIO.java:1710)[mysql-connector-java.jar:5.1.41]

 

1 ACCEPTED SOLUTION

avatar
Expert Contributor

Resolved by using `%`.* in the grant statement which removes mysql database. AWS RDS will not let us touch this database on PAAS offering.

View solution in original post

1 REPLY 1

avatar
Expert Contributor

Resolved by using `%`.* in the grant statement which removes mysql database. AWS RDS will not let us touch this database on PAAS offering.