Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-26-2016 03:48 AM
Hi All,
I am having the issue in installing the MySQL when creating the datanode. Help will be appreciated. Sorry for much trouble as I am totally new to it.
Best Regards
David
Created 01-26-2016 03:57 AM
@David Yee review your /etc/yum.repos.d/ directory for HDP-UTILS-1... entry and remove one of the entries. it says you have it listed more than once. Then do yum clean all, yum search mysql.
Created 02-19-2016 02:53 PM
run it manually and paste error here @Mark Thorson
yum install -y mysql-server
Created 02-19-2016 03:21 PM
I ran that script and it returned "No Package mysql-server available. Error: Nothing to do". I take it I need to download a mysql package (MySQL 5.6) then try it again.
Created 02-19-2016 03:28 PM
@Mark Thorson try the command below first, if no result, download manually and install
yum search all mysql
Created on 02-19-2016 06:37 PM - edited 08-19-2019 04:18 AM
Looks like mysql is installed. Do you think it could be something with the version of mysql installed? Maybe an incompatible version was installed?
Created 02-19-2016 06:40 PM
try this
yum install mysql-community-release
Created 02-19-2016 08:28 PM
I tried that and it gave me the same result as before "No package mysql-community-release available Error: Nothing to do". @Artem Ervits
Created 02-22-2016 03:08 PM
I followed the steps on this following link and I was able to successfully install MySQL. http://ahmed.amayem.com/installing-latest-version-of-mysql-on-linux-centos-6-production-server/
Created 01-26-2016 04:03 AM
Wow... thank you so much Artem. It works.
Created 01-26-2016 04:13 AM
@David Yee not to sound repetitive, but once you get a solution, please accept answers that helped resolve the question. This will help other users and this site doesn't get cluttered with unanswered threads.
Thanks
Created 01-26-2016 04:06 AM
Do the following
yum clean all yum clean dbcache yum clean metadata yum makecache rpm —rebuilddb yum history new
@David Yee Are you following any instructions to install on AWS?
It seems that this the help you really need.
See the answer to
https://community.hortonworks.com/questions/10728/ambari-fails-to-register.html
Or check out these resources.