Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-24-2016 02:56 AM
ERROR datanode.DataNode (DataXceiver.java:run(278)) - hostname:50010:DataXceiver error processing unknown operation src: /127.0.0.1:49632 dst: /127.0.0.1:50010 java.io.EOFException at java.io.DataInputStream.readShort(DataInputStream.java:315) at org.apache.hadoop.hdfs.protocol.datatransfer.Receiver.readOp(Receiver.java:58) at org.apache.hadoop.hdfs.server.datanode.DataXceiver.run(DataXceiver.java:227) at java.lang.Thread.run(Thread.java:745)
I am just adding a new data node to ambari and facing this issue.
on ambari it shows its woking but in logs i am facing this ERROR .
i cheched my firewall off and my /etc/hosts is working properly with ssh
Created 05-24-2016 05:46 AM
This is harmless message you can ignore it. which will be addressed in 2.3.0 version of ambari. Please see: https://issues.apache.org/jira/browse/AMBARI-12420
The DataNode code has been changed in 2.3.0 Ambari so that it would stop logging the EOFException if a client connected to the data transfer port and immediately closed before sending any data.
Created 05-24-2016 03:34 AM
Hi Vijay- Can you please check if the datanode disks are working and formatted properly. The problem might be related to the dfs.datanode.data.dir related disks not behaving as expected.
Created 05-24-2016 05:30 AM
I am able to access and create files in DFS
i checked fsck status from same node : Its healthy.
Created 05-24-2016 05:46 AM
This is harmless message you can ignore it. which will be addressed in 2.3.0 version of ambari. Please see: https://issues.apache.org/jira/browse/AMBARI-12420
The DataNode code has been changed in 2.3.0 Ambari so that it would stop logging the EOFException if a client connected to the data transfer port and immediately closed before sending any data.
Created 05-28-2016 12:27 AM
+1 for Joy's answer. This is just a health check from Ambari agent and it is harmless (although annoying maybe 🙂 ).
Created 07-18-2016 04:12 PM
Hello,
I'm receiving this same error as well, but for a different port - 1019, not 50010. I suppose this can be classified as the same?
ERROR datanode.DataNode (DataXceiver.java:run(278)) - sohc2v11-16.sohprod.local:1019:DataXceiver error processing unknown operation src: /30.177.244.16:42604 dst: /30.177.244.16:1019
Thanks and Regards, Braz
Created 09-22-2017 08:36 PM
@Brazelton Mann I do get the same error as well, did you find a way to resolve this.
Thanks.