Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-05-2016 02:19 AM - edited 09-16-2022 03:17 AM
Default Spark env config error in HDP2.4 installation:
#SPARK_DRIVER_MEMORY="512 Mb"
This line include a wrong config param "512 Mb", it should be "512M" without space. This will cause spark-shell yarn client start error:
Invalid initial heap size.
Suggest to update the template.
Created 05-09-2016 01:04 PM
Hi, I think that line is commented out so won't cause any issue by default and YES if user uncommented that line then it will cause error. But I will also share this to spark team to change the default template.
Thanks for the feedback.
Created 05-09-2016 01:04 PM
Hi, I think that line is commented out so won't cause any issue by default and YES if user uncommented that line then it will cause error. But I will also share this to spark team to change the default template.
Thanks for the feedback.
Created 05-11-2016 09:14 AM
I have raised a internal HDP Spark jira BUG-57627 for this issue. Thanks for raising this.
Created 05-12-2016 04:18 PM
@JR Cao please accept my post as an answer if you are good with the provided information.
Created 05-11-2016 05:42 PM