Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 12-23-2014 02:35 PM - edited 09-16-2022 02:16 AM
I started learning kite sdk today and am finding some strange behaviour.
so I had created this "users" dataset before which I want to delete and re-create. to do this I do the following steps
1. kite-sdk delete users
In order to confirm if the delete is successful I do a
kite-sdk show users
Hive table no found: default.users
OK so great users is deleted. Now I do a
kite-dataset create "users" --schema users.avsc
kite-dataset show users
and I get to see a bunch of records.... but wait... I never imported any data yet. so how come kite is showing me data in the users schema?
as of now I have just created the schema (the step of kite-dataset csv-import) has not been done yet.
so where did the data come from?? is it the data from the previous users table??
Where is this data coming from? I have not imported anything yet....
Created 12-23-2014 05:55 PM
Kite uses the Hive API to drop the table when you tell it to delete the dataset and Hive should take care of dropping the table. Can you check the log of your HiveMetastoreServer to see if there was an error on that side?
To get past the error, you can remove the directory by hand.
Created 12-23-2014 05:55 PM
Kite uses the Hive API to drop the table when you tell it to delete the dataset and Hive should take care of dropping the table. Can you check the log of your HiveMetastoreServer to see if there was an error on that side?
To get past the error, you can remove the directory by hand.
Created 12-24-2014 02:57 PM
I had to delete the directories in HDFS manually It could be that kite-dataset delete command only does a logical delete. this means it only removes the metadata.
anyways. doing kite-dataset delete and then a manual delete in HDFS works for me.