Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Deploy Client Configuration failed at upgrade to CDH5.4.1 using Cloudera Manager

avatar
Rising Star

Error in upgrading cluster:

error on upgrade.png

 

Error Detail:

ERROR2.png

 

HDFS ERROR Detail:

error on upgrade2.png

 

I have 2 CDH clusters. Respectively based on CentOS 6.5 and CentOS 6.6. Both of them Installed the CDH with Cloudera Manager manually (Installation Path C).

 

Both of them can't upgrade to 5.4.1, and have the same problem at "Deploy Client Configuration".( CM agent version is 5.4.1)

 

I have been upgraded CDH5.3.2 to 5.3.3 and 5.4.0. there was no problem.

 

Just use CM5.4.1 to manage CDH5.4.0 and not do upgrade operation, the "Deploy Client Configuration" failed too. 

 

Where to find the logs or scripts?

 

 

1 ACCEPTED SOLUTION

avatar
Rising Star

1. make a link to /usr/java/default

mkdir -p /usr/java

ln -s YOUR_JAVA_HOME /usr/java/default

 

2. add sudo nopassword to cloudera-scm user

vim /etc/sudoers

-----------------------------------

cloudera-scm    ALL=(ALL)       NOPASSWD: ALL

 

 

 

Problem solved!

View solution in original post

2 REPLIES 2

avatar
Rising Star

1. make a link to /usr/java/default

mkdir -p /usr/java

ln -s YOUR_JAVA_HOME /usr/java/default

 

2. add sudo nopassword to cloudera-scm user

vim /etc/sudoers

-----------------------------------

cloudera-scm    ALL=(ALL)       NOPASSWD: ALL

 

 

 

Problem solved!

avatar
Community Manager
I am happy to see you resolved your issue. Thank you for posting the solution as it may also help others in a similar situation. 🙂
Keep the questions coming