Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-19-2016 08:09 PM
hive> UPDATE emp SET sal = 3000.00 WHERE age = 35; FAILED: SemanticException [Error 10122]: Bucketized tables do not support INSERT INTO: Table: default.emp hive> DELETE FROM emp where sal is null; FAILED: SemanticException [Error 10122]: Bucketized tables do not support INSERT INTO: Table: default.emp
Created 07-19-2016 10:28 PM
Figured this out. I had to drop and recreate the table after turning ACID transactions on and the statements worked.
Created 07-19-2016 10:28 PM
Figured this out. I had to drop and recreate the table after turning ACID transactions on and the statements worked.
Created 07-20-2016 05:36 AM
Step-1
create table testTableNew(id int ,name string ) clustered by (id) into 2 buckets
stored as orc TBLPROPERTIES('transactional'='true');
Step-2
insert into table testTableNew values (1,'row1'),(2,'row2'),(3,'row3');
step-3
update testTableNew set name = 'updateRow2' where id = 2;
Step-4
delete from testTableNew where id = 1;
Created 03-24-2017 01:01 PM
@kishore sanchina it's working 🙂