Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 10-03-2016 07:37 PM
We installed and configured HDP-2.5.0.0. When we run a mapreduce job it fails with the diagnostics message "We crashed durring a commit". The status on Map and Reduce tasks indicate that they were successful. Following is the error observed in syslog output. How do we troubleshoot this error?Any tips will be appreciated.
2016-10-03 15:19:20,017 FATAL [main] org.apache.hadoop.mapreduce.v2.app.MRAppMaster: Error starting MRAppMaster java.io.IOException: Was asked to shut down. at org.apache.hadoop.mapreduce.v2.app.MRAppMaster$5.run(MRAppMaster.java:1559) at java.security.AccessController.doPrivileged(Native Method) at javax.security.auth.Subject.doAs(Subject.java:422) at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1724) at org.apache.hadoop.mapreduce.v2.app.MRAppMaster.initAndStartAppMaster(MRAppMaster.java:1553) at org.apache.hadoop.mapreduce.v2.app.MRAppMaster.main(MRAppMaster.java:1486) 2016-10-03 15:19:20,021 INFO [main] org.apache.hadoop.util.ExitUtil: Exiting with status 1
Created 11-02-2016 01:34 PM
This issue was a result of misconfiguration of one of the nodes having an ip address conflict with another server. Once the ip address was corrected, we were able to review the logs and address classpath errors. Thanks everyone for their suggestions.
Created 10-03-2016 07:59 PM
wrong mapreduce.jobhistory.address property's value. try to copy mapred-site.xml from the cluster
Created 10-04-2016 04:08 PM
Thank you for the suggestion. I have verified the hostname and port for mapreduce.jobhistory.address and they are accurate. We are using the copy of the config from the cluster.
Created 10-03-2016 08:01 PM
Can you check the container size allocated ? Seems you are hitting memory issue.
Created 10-04-2016 04:09 PM
Thank You for the suggestion. This appears to be plausible. Will allocate additional memory and post an update.
Created 11-02-2016 01:34 PM
This issue was a result of misconfiguration of one of the nodes having an ip address conflict with another server. Once the ip address was corrected, we were able to review the logs and address classpath errors. Thanks everyone for their suggestions.
Created 07-26-2017 03:34 PM
I faced similiar issue.
We had a HDP upgrade, still my jobs are pointing to the custom library (which are all of previous version). I have updated my custom library with latest jars. The issue is fixed.