Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-15-2016 02:10 AM
I am trying ti access the command line interface from server where I have hortonworks install but I am getting below error.Can I not access the command line?
[root@ip-xxx-xx-xx ec2-user]# hive WARNING: Use "yarn jar" to launch YARN applications. Logging initialized using configuration in file:/etc/hive/2.3.4.0-3485/0/hive-log4j.properties Exception in thread "main" java.lang.RuntimeException: org.apache.hadoop.security.AccessControlException: Permission denied: user=root, access=WRITE, inode="/user/root":hdfs:hdfs:drwxr-xr-x
Created 03-15-2016 02:11 AM
The user you are trying to access the directory with is root and it does not have permission. Either provide root access to /user/root/ or change to user hdfs via su - hdfs. Current /user/root/ is owned by hdfs according to your log.
Created 03-15-2016 02:10 AM
sudo -u hdfs hdfs dfs -mkdir /user/root sudo -u hdfs hdfs dfs -chown -R root:hdfs /user/root
Created 10-04-2016 07:35 AM
@Artem Ervits I was facing the same issue. This solution worked for me. Thank you!
Created 03-15-2016 02:11 AM
The user you are trying to access the directory with is root and it does not have permission. Either provide root access to /user/root/ or change to user hdfs via su - hdfs. Current /user/root/ is owned by hdfs according to your log.