Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-26-2015 07:33 PM - edited 09-16-2022 02:46 AM
When I run the following command:
sqoop import-all-tables \
-m 1 \
--connect jdbc:mysql://quickstart:3306/retail_db \
--username=retail_dba \
--password=cloudera \
--compression-codec=snappy \
--as-avrodatafile \
--warehouse-dir=/user/hive/warehouseI get the following error:
/usr/lib/sqoop/bin/sqoop: line 101: /usr/jars/bin/hadoop: No such file or directory
/usr/lib/sqoop/bin/sqoop: line 101: exec: /usr/jars/bin/hadoop: cannot execute: No such file or directory
I tried to remove that file using:
hadoop fs -rm -r -skipTrash /usr/jars/bin/hadoop
I still get the same error!!!!!
any suggestions????
Created 10-27-2015 05:19 AM
Perhaps this other thread will be of assistance.
tutorial exercise 2: no tables
Created on 10-28-2015 06:04 AM - edited 10-28-2015 06:22 AM
Thanks for following up. Problem is solved; I ran hive server and made the namenode leave the safe mode. Then the command included in the thread you posted worked finally.
Created 10-27-2015 05:19 AM
Perhaps this other thread will be of assistance.
tutorial exercise 2: no tables
Created 10-27-2015 05:15 PM
Thanks for the suggestion! I tried the suggested commands but I still have the same problem.
Created 10-28-2015 04:51 AM
Sorry to hear that. Hopefully someone more knowledgable than I will jump in with something better.
Created on 10-28-2015 06:04 AM - edited 10-28-2015 06:22 AM
Thanks for following up. Problem is solved; I ran hive server and made the namenode leave the safe mode. Then the command included in the thread you posted worked finally.
Created 10-28-2015 06:19 AM